Include Hashes for Partial .mar Files in MD5SUMS and SHA1SUMS files.

RESOLVED DUPLICATE of bug 607978

Status

Release Engineering
General
P5
enhancement
RESOLVED DUPLICATE of bug 607978
8 years ago
5 years ago

People

(Reporter: David E. Ross, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [updates][signing], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.11) Gecko/20100701 SeaMonkey/2.0.6, NOT Firefox/3.6.3
Build Identifier: 

I maintain an archive of software updates for my PC and log each update as it is installed (a habit developed when I was in charge of configuration management for a large software project for the U.S. military).  For Mozilla-based products (e.g., Thunderbird), this means I download the partial .mar file via FTP and then install the patch using a script I developed.  

I want to use either an MD5 or SHA1 hash to verify the integrity of the download before I install it.  For Firefox and Thunderbird under Windows, these hashes are already available for complete .mar files and for executable installation files but not for partial .mar files.  


Reproducible: Always




For SeaMonkey, the hashes are available for partial .mar files.

Updated

8 years ago
Priority: -- → P5
Whiteboard: [updates][signing]
(Reporter)

Comment 1

7 years ago
Oops!!  I submitted the same bug report twice, three months apart.  Although this one was earlier and thus would have priority, bug #607978 has more details and discussion.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 607978
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.