Library Menu Items for Organize Bookmarks->Organize are grayed out if not selected (mouseOver() event)

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: vladmaniac, Unassigned)

Tracking

4.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3pre) Gecko/20100722 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3pre) Gecko/20100722 Minefield/4.0b3pre

Could be related to one of the "library being slow" known bugs, but I am reporting it as an UI problem, just to be sure. 

Reproducible: Always

Steps to Reproduce:
1.Go to Bookmarks -> Organize Bookmarks
2.Select History Section
3.Then select a folder in the View Pane (suggest Bookmarks Toolbar) and go to Organize -> New Bookmark.
4.Inspect Menu 
Actual Results:  
Menu buttons for New Bookmark, New Folder, New Separator are grayed out until selected from keyboard action or mouseOver() event.

Expected Results:  
All Menu items should be active and properly marked according to navigation hierarchy. 

Note: please see screenshots to notice exact behavior of menu.
(Reporter)

Comment 1

7 years ago
Created attachment 459739 [details]
screenshot_no selection

this is a screenshot capturing the situation of no selecting the items. Inspect the Menu is grayed out.
(Reporter)

Comment 2

7 years ago
Created attachment 459740 [details]
screenshot_selection

This captures the case when performing mouseOver() event. See the menu is being activated as selection is performed. Only the items being selected are activated.
(Reporter)

Updated

7 years ago
Summary: Library Menu for Organize Bookmarks are grayed out if not selected (mouse on top event) → Library Menu Items for Organize Bookmarks->Organize are grayed out if not selected (mouseOver() event)
Still reproducible in 4.0 final?

Updated

7 years ago
Version: unspecified → 4.0 Branch
cannot reproduce
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.