Closed Bug 581295 Opened 9 years ago Closed 9 years ago

Site panel doesn't disappear when tapping anywhere but the popup box UI

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ahoza, Assigned: mfinkle)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3pre) Gecko/20100722 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (Android; Linux armv7l;en-US;rv:2.0b3pre) Gecko/20100722 Namoroka / 4.0b3pre Fennec/2.0a1pre

Popup box UI displayed when tapping on sites favicon should disappear when tapping in content's page.

Reproducible: Always

Steps to Reproduce:
1.Load http://bugzilla.mozilla.org
2.Click the site icon/favicon to the left of "bugzilla.mozilla.org" in the URL bar
3.Popup with info is presented
4.With pop up open, click anywhere but the popup box UI.

Actual Results:  
The popup does not disappear unless one taps the site's favicon again.

Expected Results:  
After Step 4, the Site Panel should close and disappear.

https://litmus.mozilla.org/show_test.cgi?id=7285

Device: HTC Desire A8181
Works fine on Linux desktop and N900. Android only?
OS: Other → Android
Hardware: Other → ARM
I haven't noticed it on Nokia N900 either.
As for Android, I couldn't reproduce this on clean install, using the same build 
I'll investigate this and see if I can find steps to reproduce it.
Confirmed on build:

Mozilla/5.0 (Android; U; Linux armv71; en-US; rv:2.0b2pre) Gecko/20100805 Namoroka/4.0b3pre Fennec/2.0a1pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
tracking-fennec: --- → ?
I could not reproduce this using the 2010-08-05 Android mozilla-central nightly on Nexus One.
the site panel dismisses when I click on the content outside of the panel, closing this as wfm.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
What build id are using, Brad? Is it a nightly build or a private build?
This is reproducible always with the build id : Mozilla /5.0 (Android;Linux armv7l; rv:2.0b5pre)Gecko/20100824 Namoroka/4.0b5pre Fennec /2.0a1pre
Device: HTC Desire A8181 with the one additional step 

Steps to Reproduce:
1.Load http://bugzilla.mozilla.org (or any other page)
2.Click the site icon/favicon to the left of "bugzilla.mozilla.org" in the URL
bar
3.Popup with info is presented
4.Reload the page while site panel is still open
5.Click anywhere but the popup box UI.
Reproducible also on Nokia N900, buildID is: Mozilla/5.0 (X11; Linux armv7l;
rv:2.0b5pre) Gecko/20100825 Namoroka/4.0b5pre Fennec/2.0b1pre with the steps mentioned above.
Reopen the bug
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Step 4, reloading the page, should close the site menu. let's fix that part.
Attached patch patchSplinter Review
This patch adds a listener for the "URLChanged" event and hides the site menu on page reloads. Same idea we use for Find Bar and Form Assistant.
Assignee: nobody → mark.finkle
Attachment #469059 - Flags: review?(21)
Comment on attachment 469059 [details] [diff] [review]
patch

>diff --git a/chrome/content/browser.js b/chrome/content/browser.js
>+
>+  handleEvent: function(aEvent) {
>+    if (aEvent.type == "URLChanged" && !this._identityPopup.hidden)
>+     this.hide();
>   }

Nit: It looks like it missed a space
Attachment #469059 - Flags: review?(21) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/88befe20bf4e
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
verified FIXED on build:

Mozilla/5.0 (Android; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100825 Namoroka/4.0b5pre Fennec/2.0a1pre
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.