Scrolling disabled in Confluence online editor preview window after upgrade to 3.6.7

VERIFIED DUPLICATE of bug 581240

Status

()

VERIFIED DUPLICATE of bug 581240
8 years ago
8 years ago

People

(Reporter: typothecary, Unassigned)

Tracking

({regression})

1.9.2 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7 ( .NET CLR 3.5.30729)

This works fine in 3.6.6 and stops working 3.6.7. Scrolling using the mouse wheel is unaffected in an ordinary display window and within the edit window itself in Confluence (wiki software). But if you open an edit window and click Preview, scrolling is disabled on the preview. I've tried setting/unsetting Tools > Options > Advanced > General > Use autoscrolling but it makes no difference. 
I've tried 2 different mice and 2 different USB ports on computer. Tried different computer, again it was fine in 3.6.6. until ff upgraded itself to 3.6.7 and the problem recurs. 

Reproducible: Always

Steps to Reproduce:
1. Open Confluence 2.9.1 editor in wiki markup mode
2. Click Preview

Actual Results:  
Scrolling is disabled entirely. The screen bounces up and down but doesn't scroll.

Expected Results:  
Using the mouse wheel to scroll should work in the same way it always has. 

Using default theme in FF. 

We use FF as a business application because of the master password feature. This is a critical bug for my company because Confluence is our online documentation system. It will be a major inconvenience for our approximately 800 users but I accept that it might not be a problem for ordinary users. We can work around this by rolling back to 3.6.6 and declining to update beyond that version.
(Reporter)

Updated

8 years ago
Summary: Scolling disabled in Confluence online editor preview window after upgrade to 3.6.7 → Scrolling disabled in Confluence online editor preview window after upgrade to 3.6.7
We need a public testcase.
Do you already tried http://support.mozilla.com/en-US/kb/Safe+Mode ?

Comment 2

8 years ago
I've got the same results.  After upgrading to Firefox 3.6.7, the preview window in Confluence wiki version 2.10.1 only shows a few lines (apparently whatever fits on one screen), with no way to scroll up or down.  The controls above and below the preview pane are displayed, but the preview pane itself appears as if that's all the lines there are on the page.  I tried upgrading to 3.6.8, but saw the same problem.  Reverting to 3.6.6, the problem went away.
There is nothing we can do without a testcase
Can you reproduce the issue with http://sandbox.onconfluence.com/dashboard.action?story=0&os_username=intranet&os_password=sandbox ?
Component: General → Layout
Keywords: regression
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.9.2 Branch
> There is nothing we can do without a testcase

That's not quite true.  We can also get some data out of someone who can reproduce using branch nighlies to narrow down when the problem appeared.  leth@alum.mit.edu, Kath, are you willing to do that, in case we can't find a public URL showing the problem?

Comment 5

8 years ago
Yes, I was able to reproduce the problem on the public Confluence sandbox at the URL shown above.  Here's what I did (using Firefox 3.6.7):

1. Went to this link:
http://sandbox.onconfluence.com/dashboard.action?story=0&os_username=intranet&os_password=sandbox

2. Selected Add Page under the "Anything Goes!" space, using "Start with a blank page" in the Template field.

3. Copied more than a screenful of text from another window and pasted it into the edit window (it doesn't matter whether you do this under the Rich Text or the Wiki Markup tab).

4. Clicked the preview tab.  The display shows only as much of the text as fits in the small page display pane, with no way to access the rest of the text.

I tried the exact same sequence using Firefox 3.6.6, and the problem did not occur. The entire text is shown in the preview tab (the page display pane is sized to fit the entire text, so you can scroll vertically to see it all).

I did not test version 3.6.8 with this same public Confluence wiki site, but on our internal wiki the same problem is exhibited with 3.6.8.
(Reporter)

Comment 6

8 years ago
I can confirm that the problem also exists when running 3.6.7 in safe mode.
(Reporter)

Comment 7

8 years ago
I have reproduced the problem in the public sandbox here as well, link below. I don't know how long the example will stay available on the Confluence sandbox. That example page is version 3.3 of Confluence; we use version 2.9.1, but the problem is the same in both Confluence versions. 

http://sandbox.onconfluence.com/display/~intranet/Firefox+3.6.7+prevents+scrolling+in+edit+preview+mode
OK, with the steps in comment 5 I see the bug on 3.6.8.  I don't see the bug on trunk...

Investigating.
So looks like between the 3.6.6 branchpoint and 3.6.7 ship there were two behavior changes:

1)  The div holding the text became smaller (but scrollable).
2)  The div became unscrollable.

in that order.  Narrowing down what caused those.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Er, I might be confused in comment 9.  I think I forgot to click preview once.  Now I only see one regression, that reduced the height but kept the div unscrollable.
Bisect says:

The first bad revision is:
changeset:   34301:cc47b92e73d8
user:        Boris Zbarsky <bzbarsky@mit.edu>
date:        Mon Mar 08 19:30:02 2010 -0500
summary:     Bug 550882.  Make sure to create scrollbars for the viewport even if it's currently overflow:hidden, since various changes to <body> and the like can change the propagated overflow.  r=roc, a=dveditz

which is... curious.  In the failing case, there is no inline style height set on the <iframe>; in the passing case such a height is set.
Oh, I bet this is a dup of bug 581240.
Blocks: 550882
Depends on: 581240
Yep, indeed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
No longer depends on: 581240
Resolution: --- → DUPLICATE
Duplicate of bug: 581240
verified per bug 581240#c9
Thanks Boris for all the work to find the reason for this regression
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.