Author,description fileld not saved in page properties

VERIFIED DUPLICATE of bug 60129

Status

()

Core
Editor
P3
normal
VERIFIED DUPLICATE of bug 60129
18 years ago
17 years ago

People

(Reporter: Nasiruddin M.S, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.6
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: suntrak-n6)

(Reporter)

Description

18 years ago
netscape build:10/24
platform : solaris2.8

(1) launch netscape and launch composer
(2) type some letters in composer.
(3) go to 'format->page title and properties'. fill the title,author and
description fields in 'page properties' dialog.
(4) press o.k, save the file and close the composer.
(5) Open the same file again in composer. go to 'format->page title and
properties' and change the title. save the changes and close the file.
(6) Open the same file again in composer,it will not show the previously saved
title.

The summary is the changes made to the title field in 'page properties' dialog
is not saved.
Changing component to Editor and reassigning.
Assignee: kmcclusk → beppe
Component: Compositor → Editor
QA Contact: petersen → sujay

Updated

17 years ago
Blocks: 45863

Updated

17 years ago
No longer blocks: 45863
(Reporter)

Updated

17 years ago
Whiteboard: suntrak-n6

Updated

17 years ago
Assignee: beppe → cmanske
Target Milestone: --- → mozilla0.6

Comment 2

17 years ago
I can't reproduce this problem on a mozilla trunk build from today on Macintosh.
 However, I do see that after step 4 above and opening the same file again, I
can't save by just changing the page title, I need to type some text or do
something else that causes the file to get "dirty."  Maybe this is the problem?
 If you didn't really save the new title (because the shortcut key was disabled
because the flag was incorrect), then opening the file again will look just as
it did before.

If I'm right, this bug should be about changing the title not setting the
"dirty" flag.  (If I'm wrong and this is a solaris problem that isn't showing up
on Mac then my comments above should be put into a new bug.)

Reassign to cmanske since he's done much of the work for this dialog.
(Assignee)

Comment 3

17 years ago
The issue here is not using transaction system to set <title> and thus the
document is not being marked as "modified" after user changes title.


*** This bug has been marked as a duplicate of 60129 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
verified in 11/8 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.