Last Comment Bug 581468 - warning: signed and unsigned type in conditional expression in XPT_DoString
: warning: signed and unsigned type in conditional expression in XPT_DoString
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Atul Aggarwal
:
Mentors:
Depends on:
Blocks: buildwarning
  Show dependency treegraph
 
Reported: 2010-07-23 09:42 PDT by Josh Matthews [:jdm]
Modified: 2011-09-01 01:54 PDT (History)
1 user (show)
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 to fix unsigned, signed match (885 bytes, patch)
2011-08-31 12:11 PDT, Atul Aggarwal
benjamin: review+
Details | Diff | Review

Description Josh Matthews [:jdm] 2010-07-23 09:42:53 PDT
xpcom/typelib/xpt/src/xpt_xdr.c: In function ‘XPT_DoString’:
xpcom/typelib/xpt/src/xpt_xdr.c:409: warning: signed and unsigned type in conditional expression
Comment 1 Atul Aggarwal 2011-08-31 12:11:56 PDT
Created attachment 557271 [details] [diff] [review]
Patch v1 to fix unsigned, signed match

It was difficult to track due to macro but gcc -E helped finally.
Comment 2 Ed Morley [:emorley] 2011-08-31 15:15:57 PDT
In my queue :-)
Comment 4 Ed Morley [:emorley] 2011-09-01 01:54:52 PDT
http://hg.mozilla.org/mozilla-central/rev/6c63fffe3b21

Note You need to log in before you can comment on or make changes to this bug.