www.mlslistings.com, "Begin Search" button not working

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Ninoschka Baca, Assigned: karnaze (gone))

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Branch build 2000-10-26-09MN6: NT4

Overview: There is a page on the mlslistings.com site which has a
"Begin Search" button which doesn't work consistently.

Steps to reproduce:
1. Go to www.mlslistings.com
2. Select the "Property Search" link
3. Type "Mountain View" in the 'Search by City Name" text box, select the
"Continue" button
4. On the next page select the "Continue" button
5. Select the "Begin Search" button

Actual Results: The button does nothing. The console reports
"Error loading URL JavaScript:checkMe():804b0002
Gdk-Message: Got event for unknown window: 0x3400819"

Workaround: I tried:
- reselecting the button and it doesn't work.
- resizing the window doesn't work
- reloading the page doesn't always work but sometimes it does. When it does
work, the "Begin Search" button will move from the right to a position ontop of the
"From$     to $     " text boxes. When it repositions itself then it works. Also
after repositioning, mousing over the button now displays "JavaScript:checkMe()"
in the status area when it displayed nothing before.

Expected Results: Selecting the "Begin Search" should work immediately.

Additional Information:
- Using 4.6, the "Search Begin" button works.
(Reporter)

Comment 1

18 years ago
Adding Seth to the Cc: list since he also saw the problem.
It works for me with todays branch build on WINNT.
Marking WORKSFORME.

Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
I'm able to reproduce this.

when I make the window narrower, I'm more likely to see this.

It doesn't happen ever time.

I'll attach two screen shots.

when it works, the "Begin Search" button is in a different spot then when it fails.

I just noticed that when it works, I can click anywhere on the button to make it
work.

when it fails, only clicking on the very left edge of the button works.  (only
on the very left edge do I see the "JavaScript:checkMe()" url show up in the
status text at the bottom of the browser.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Created attachment 18148 [details]
screen shot when it doesn't work.
kevin, I wonder if this related to http://bugscape/show_bug.cgi?id=2977 and
http://bugscape/show_bug.cgi?id=2416

in 2416, nbaca wrote:

"I had to place the cursor on the 'A' in the Activation button and then
press the button in order for it to work. When the Activation button is pressed
it's hard to tell if it's disabled, I can see dashed lines surrounding the
'Activation' text."

here's my wacky-uneducated guess (I'm clearly no layout expert)

both pages have buttons in table cells.  perhaps with async reflow we build up
the table but don't update everything after the image loads (on in the case of
#2416, after the document.write() of the html for the button within the cell).

the result is the region that would normally be associated with the buttons is
not the whole image, just the previous region taken up by the empty cell.

in both cases, clicking on the left most part of the button worked.

does that make any sense?
Seth: I think you're on the right track. It could be a problem where the table
cell's size has not been expanded after the image has been loaded.

CC'ing karnaze@netscape.com
Re-assigning to rods@netscape.com
Assignee: clayton → rods
Status: REOPENED → NEW

Comment 8

18 years ago
I am reassigning this to karnaze, the odds of the table layout it wrong are 
higher then the button not working.

When I first got to the page the button was way out tothe right, just like the 
screen shot of it not working. Then when I went back to the page (by going 
"Back" and then hitting continue again). It layed out like the working screen 
shot.

I really do think this is a table layout issue.
Assignee: rods → karnaze
(Assignee)

Comment 9

17 years ago
I'm not seeing the problem. Marking worksforme.
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

17 years ago
Build 2001-03-28-04: NT4, it works for me too.
You need to log in before you can comment on or make changes to this bug.