Disabled OPTION in SELECT internally selected with keyboard

NEW
Unassigned

Status

()

8 years ago
8 years ago

People

(Reporter: duke_the_killer, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET CLR 1.1.4322; .NET4.0C)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7

Two options begin with the same letter (T)
The first one is disabled

While list has focus, pressing T will internally select the disabled option although the highlighted one stays the same
Confirm by pressing the up or down arrow

Reproducible: Always

Steps to Reproduce:
1. Open list
2. Press T
3. Optionnally, press the up arrow
Actual Results:  
Option from 1. stays selected, but internally Two is selected because pressing the up arrow then selects One

Expected Results:  
It should have selected Three

Pressing T a second time does not even select Three

Same result with list open (when you see all options) or closed (when you see the selected option)

Yes, Internet Explorer 8/9 have a very similar bug, Two becomes the selected option when the list is closed
(Reporter)

Comment 1

8 years ago
Wanted to say SeaMonkey 2.0.6 is also affected

Not sure whether to report right now, or let you handle that after it's fixed
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Comment 2

8 years ago
For "fun", I went looking for regressions

None. Reproducable from Firefox 1 to 4 on Windows
Also tried 3.6 on Centos

*changing some flags
(Reporter)

Updated

8 years ago
Component: General → General
OS: Windows 7 → All
Product: Firefox → Core
Hardware: x86 → All
Version: 3.6 Branch → Trunk
QA Contact: general → general

Comment 3

8 years ago
I can confirm this with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b6pre) Gecko/20100901 Firefox/4.0b6pre. Bug 451200 is similar to this, but is not an exact duplicate.
Status: UNCONFIRMED → NEW
Component: General → Layout: Form Controls
Ever confirmed: true
Keywords: testcase
QA Contact: general → layout.form-controls

Comment 4

8 years ago
Created attachment 471599 [details]
testcase from the reporter
You need to log in before you can comment on or make changes to this bug.