Closed Bug 581838 Opened 9 years ago Closed 9 years ago

Make code to mark files as sparse use JS ctypes

Categories

(MailNews Core :: Testing Infrastructure, defect)

x86
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.3a1

People

(Reporter: rain1, Assigned: rain1)

References

Details

Attachments

(2 files)

Attached patch patchSplinter Review
Now that we have JavaScript ctypes, we should use them instead of relying on potentially painful helper executables (c.f. bug 559681). JS ctypes are surprisingly simple to use.
Attachment #460164 - Flags: review?(bugzilla)
Comment on attachment 460164 [details] [diff] [review]
patch

This looks good, thanks for the patch.
Attachment #460164 - Flags: review?(bugzilla) → review+
Comment on attachment 460164 [details] [diff] [review]
patch

>--- a/mailnews/Makefile.in
>+++ b/mailnews/Makefile.in
> 
>-ifdef ENABLE_TESTS
>-PARALLEL_DIRS	+= test
>-endif
>-

Umm, wait, that doesn't sound right to me. We should still enter test/ when building, or we will not use any of the stuff in there any more, including the xpcshell tests. IIRC, this block is needed to go in that directory and install all the xpcshell test stuff in there.
(In reply to comment #2)
> Umm, wait, that doesn't sound right to me. We should still enter test/ when
> building, or we will not use any of the stuff in there any more, including the
> xpcshell tests. IIRC, this block is needed to go in that directory and install
> all the xpcshell test stuff in there.

No actually:

http://hg.mozilla.org/comm-central/annotate/23a7e239ace7/mailnews/test/Makefile.in

only includes the support stuff for LargeOfflineStoreHelper which is now removed.


The files that are in that test directory are actually copied from here:

http://hg.mozilla.org/comm-central/file/23a7e239ace7/mailnews/Makefile.in#l85

They should probably have an ifdef ENABLE_TESTS around them, but I'd prefer to keep those there as it means one less directory that make has to go into.
Ah, that's confusing, but OK, what of our build system isn't. ;-)

I was thrown off by that test/Makefile.in installing something in the xpcshell tests dir. ;-)
Yeah, it's a little confusing. I'll add a note to the commit message.
http://hg.mozilla.org/comm-central/rev/9d1f0b2cede7
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.2a1
Backed out due to bustage ("cannot find symbol"), seemingly caused by bug 585175.
Status: RESOLVED → REOPENED
Depends on: 585175
Resolution: FIXED → ---
http://hg.mozilla.org/comm-central/rev/7452cc26df1d

(I had to s/stdcall_abi/winapi_abi/g.)
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
So it turns out JS doesn't have Exceptions, it has Errors. Huge thanks to Neil for catching it!

Neil rs'd this patch over IRC.
Attachment #467209 - Flags: review+
You need to log in before you can comment on or make changes to this bug.