64-bit Firefox can't open 32-bit plugins

RESOLVED DUPLICATE of bug 559142

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 559142
8 years ago
8 years ago

People

(Reporter: Andre-John Mas, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:2.0b1) Gecko/20100628 Firefox/4.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:2.0b1) Gecko/20100628 Firefox/4.0b1

The issue is that if I run 64-bit Firefox 4.0b1 then certain plugins, such as Flash, which are 32-bit will not load.

With the OOPP approach it may be useful to include support for allowing 32-bit plugins to run in a 32-bit sub-process when its 64-bit equivalent is not available. I imagine this would be possible with this new architecture?

I am not sure whether we should treat this as a feature request or a bug, so I will let the developers decide. In many ways it is a feature request, but the behaviour may appear as a bug to many general users.

Reproducible: Always
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 559142
You need to log in before you can comment on or make changes to this bug.