Memory leak when downloading larger files (i.e. greater than 500MB)

RESOLVED DUPLICATE of bug 564710

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 564710
8 years ago
8 years ago

People

(Reporter: gotgod86, Unassigned)

Tracking

3.6 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

For two days in a row now, I've downloaded two things. A video game demo and today I downloaded Ubuntu. Each time, towards the end of the download, Firefox gets VERY slow. So I'll look in the processes tab in the Task Manager. Both times this happened, when I look at the 'firefox.exe' process it says that it is using upwards of 1.5GB of my ram, precisely "1,543,097 KB" Obviously Firefox isn't designed to use that much space, so I decided to report it since it's happened multiple times.

Reproducible: Sometimes

Steps to Reproduce:
1. Begin downloading a file larger than 500MB
2. While file is downloading, browse the web in multiple tabs.
3. Continue browsing, as the file downloads, and Firefox will eventually crash.

This will reproduce the problem about 1/3 times its done.
Actual Results:  
Firefox takes up too much RAM and crashes.



Expected Results:  
Continued the download and finished it normally.
Is the Issue reproduceable to just Downloading certain Files?
What Files (URL)?

Does it happen running Fx in Safe-Mode (https://support.mozilla.com/en-US/kb/Safe+Mode)? If not, can you name the causing Extension + Version?

You mention "Crashes": can you get a Stacktrace using the Steps mention here:
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report ?
Version: unspecified → 3.6 Branch
This is a known issue in some Firebug versions
Reporter, any replies to the above comments?
Severity: critical → major

Comment 4

8 years ago
Since there was no reply from the reporter, duping to another bug about this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 564710
You need to log in before you can comment on or make changes to this bug.