Closed Bug 581850 Opened 11 years ago Closed 10 years ago

Stop generating 'charCode is meaningless' warnings.

Categories

(Core :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: Mardak, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

They fill up the error console from all sorts of sites and can slow down the whole browser if you happen to have the error console open and type on certain sites like an email or chat in gmail.
UI issue, not core issue, I'd think.
Component: DOM: Events → General
Product: Core → Firefox
QA Contact: events → general
Well, we could give the error only once per document - the same way we warn
about boxobject usage.
I'm sure they're actually slowing us down when the console isn't open, just less so: we're still constructing and dispatching the console message.  Can we just disable the warning entirely?  It doesn't seem to be having much effect on Google Docs or Twitter, where I get the warning (twice!) for every keystroke...
Product: Firefox → Core
QA Contact: general → general
I think we should do comment 2.
I think we should really stop emitting these.

They are triggered by libraries like jQuery.  The warning doesn't provide source coordinates, so there's no reasonable way to track them down if you suddenly see them in your app.  It hasn't motivated gmail or twitter or other sites to fix anything ever, as far as I can see.

I'm changing the title here, and I'll find someone to work up a patch.
Summary: Allow 'charCode is meaningless' warnings to be hidden → Stop generating 'charCode is meaningless' warnings.
Attached patch remove not-so-useful warnings (obsolete) — Splinter Review
Attachment #488064 - Flags: review?(jst)
Apparently I could remove ReportWrongPropertyAccessWarning.
Attached patch remove even moreSplinter Review
Attachment #488064 - Attachment is obsolete: true
Attachment #488075 - Flags: review?(jst)
Attachment #488064 - Flags: review?(jst)
Attachment #488075 - Flags: review?(jst)
Attachment #488075 - Flags: review+
Attachment #488075 - Flags: approval2.0+
I think this may have L10N impact...
Well, some localizations may now have a string which isn't used.
Removing strings is very low impact, it's fine for that to happen after beta 7.
http://hg.mozilla.org/mozilla-central/rev/72dcbb2cb6a5
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 634863
You need to log in before you can comment on or make changes to this bug.