Closed Bug 581880 Opened 11 years ago Closed 11 years ago

Lightning and Sunbird set incorrect until date when create a new event for some time zones.

Categories

(Calendar :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 566149

People

(Reporter: irina.arkhipets, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.1.11) Gecko/20100701 Firefox/3.5.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.2.7) Gecko/20100713 Lightning/1.0b2 Thunderbird/3.1.1

Until date gets shifted on one day left when I am creating a new, not all-day event for some start time / time zone combinations. 

It seems like it depends on time zone time shift and is reproducible in all the Mozilla clients I have: Lightning 1.0, Sunbird 0.9 and Sunbird 1.0 beta.

All is OK for me in Apple iCal client.

The problem does not appear when I update existing event.


Reproducible: Always

Steps to Reproduce:
1. Start Mozilla Lightning 1.0b2 on Windows XP with Russia/Novosibirsk time zone; Lightning time zone is also Russia/Novosibirsk.
2. In your home calendar select the "File" -> "New" -> "Event" menu item and create a new event titled "test", started on 7/26/2010 on 1:00 AM with one hour duration, repeat every day until the 1/28/2010. Click the OK button.

Actual Results:  
Test event has two instances: on 26-July and 27-July. If I am opening it again, its until date is 7/27/2010.

Expected Results:  
Test event has three instances: on 26-July, 27-July and 28-July. If I am opening it again, its until date is 7/28/2010.

This bug does not appear if I update an existing event: if I open the test event created on the previous step again and change its until date to 7/28/2010, third instance on 27-July appears in my calendar.

This bug is not reproducible if created event starts on the evening, for example, at 20:00 PM. Please, note: time shift for Novosibirsk is GMT+6 now, but the bug is still reproducible, for example, for 11:00 AM start time.
Could it be bug 566149?
Is the until date wrong and the last occurrence missing if you create a new event and modify the start time hour to any hour earlier than that one proposed by default in the dialog?
Yes, probably this is a duplicate. At least, now it is 6:43 PM on my workstation and the meeting started at 7:00 PM is OK whereas another one started at 6:00 PM loses last instance.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 566149
You need to log in before you can comment on or make changes to this bug.