If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add "Undo Close Tab" to the tab strip's context menu

RESOLVED DUPLICATE of bug 1014313

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 1014313
7 years ago
a year ago

People

(Reporter: Ian Pottinger, Unassigned, Mentored)

Tracking

Trunk
Points:
3

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [outreachy-12])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
This bug's intent is to expand to target area for accessing the "Undo Close Tab" feature for mouse users.

I'm not one for having 50+ tabs open at once.  The Test Pilot study highlighted that I usually have only 3-4 tabs open at any given time and very rarely have at max more than 5-6.  Now with App Tabs hosting three of those usually opened tabs, the tab strip is a very empty place and to undo a closed tab requires targeting one of those three relative small App Tabs at the far left of the screen.  I find myself constantly right-clicking the empty tab strip expecting to see "Undo Close Tab."
(Reporter)

Comment 1

7 years ago
I've also submitted bug 581913 to add "Undo Close Tab" to the New-Tab button's context menu for the same reasons.
Undo Close Tab is already in the tab strip context menu: http://grab.by/5AuQ

What am I missing here?
(Reporter)

Comment 3

7 years ago
Created attachment 460217 [details]
Tab strip's context menu on trunk

I'm not seeing it on the trunk.  I get the customization menu instead.
Oh, that's caused by bug 578614. INVALID, since we're not going to be adding "Undo Close Tab" to the toolbar context menu, but see bug 581646 which might end up reverting bug 578614.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #4)
> Oh, that's caused by bug 578614. INVALID, since we're not going to be adding
> "Undo Close Tab" to the toolbar context menu, but see bug 581646 which might
> end up reverting bug 578614.

I think we should add "Undo Close Tab" to the toolbar context menu if the toolbar is TabsToolbar. Consider the case where the user has tabs-on-top, the browser maximized, and the user has two tabs open. They close one of their tabs and then right-click on the empty area of the tabs toolbar.

The context menu item fits geo-spatially and continues the metaphor of the whole toolbar being meant for tabs.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
See Also: → bug 581913
Mentor: jaws@mozilla.com
Points: --- → 3
Whiteboard: [outreachy-12]
This was fixed as part of the work in bug 1014313.
Status: REOPENED → RESOLVED
Last Resolved: 7 years agoa year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1014313
You need to log in before you can comment on or make changes to this bug.