WHY no way to setup account manually

RESOLVED DUPLICATE of bug 549045

Status

Thunderbird
Account Manager
RESOLVED DUPLICATE of bug 549045
7 years ago
7 years ago

People

(Reporter: Reindl Harald, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.8) Gecko/20100724 Remi/fc12 Firefox/3.6.8
Build Identifier: 

It is a pain in tunderbird >= 3.1 to try automatically create a new mailaccount, there should be first a option "assistant" or "manually" because this does NEVER work as wanted for small companys like us

As mailadmin today i had to enable a new imap-account and the first was thunderbird did was to try "pop3" with "pop3.domain.tld"

Really: it is the wrong way if a advanced user has problems to get a new account with the first try

We are hosting > 100 domains and there is exactly ONE servername for smtp/pop3/imap because it is not funny if a ip changes to edit every domain only for have "pop3.domain.tld"

With the new way it is impossible to tell a user what he has to do 

Reproducible: Always

Actual Results:  
really bad default settings

Expected Results:  
let me choose my servernames, servertype, ports if i want so and give me only the OPTION to do this automatic
Whiteboard: dupme

Comment 1

7 years ago
Just press stop and then manual setup button. Also you can use Mission Control Desktop AKA AutoConfig, with provided all settings need for setup.

Comment 2

7 years ago
Hi Reindl,

You'll find some interesting reading about this at bug 580216, but ultimately apparently this buig is being covered by bug 549045, so if you agree please mark as duplicate...

Comment 3

7 years ago
(In reply to comment #1)
> Just press stop and then manual setup button.

Thats is *not* a satisfactory solution to this problem - what if I decdie I want an IMAP account and it created a POP account? There is no way to change it.

> Also you can use Mission Control Desktop AKA AutoConfig, with provided all
> settings need for setup.

Fails to work reliably at this point...
(In reply to comment #3)

> > Also you can use Mission Control Desktop AKA AutoConfig, with provided all
> > settings need for setup.
> 
> Fails to work reliably at this point...

Can you elaborate on that on our enterprise mailing list at https://mail.mozilla.org/listinfo/tb-enterprise ?

Updated

7 years ago
Component: Preferences → Account Manager
QA Contact: preferences → account-manager
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 549045

Comment 6

7 years ago
> We are hosting > 100 domains

<https://developer.mozilla.org/en/Thunderbird/Autoconfiguration#Domain_hoster>

> it is not funny if a ip changes to edit every domain
> only for have "pop3.domain.tld"

You could use DNS CNAME.

---

Bug 549045 will still start automatic detection first, because for the majority of users that works and often better than manual.
However, it will make switching to manual mode much more obvious and working better.
(Reporter)

Comment 7

7 years ago
Does not change the fact that starting with autoconfig is stoopid and "but you must dedicate one IP address to the autoconfig web server and the web server must be configured to the content to any requested domain." is a joke because give me ONE reason why this can not be a normal name based host with a cname for every domain?

The concept is as stoopid as possible because as example our server provides imap and pop3 and you never ever can know what the user wants, so the software has to make a question and not choose pop3 while i want a imap-account or the other direction

Please add in the configuration two buttons "autoamtic" and "manually" and all are happy

Comment 8

7 years ago
> is a joke because
> stoopid

Watch your language and attitude, please. etiquette warning.

> give me ONE reason why this can not be a normal name based host with a
> cname for every domain?

offtopic and answered by email.

> Please add in the configuration two buttons "autoamtic" and "manually"

There is already a "manual" button. After bug 549045, it will actually work.

Not doing automatic detection is not a single bit faster than as-is. In both cases, it's just one button press on "Manual" for you.

> and all are happy

No. I said above that the automatic is, in many cases, better than manual, because e.g. we know SSL configs that the user is not even aware they exist.
(Reporter)

Comment 9

7 years ago
The real problem with such things is that we create more and more users without knowing anything about their computer.

Make things easy as possible but not easier as needed should forced

My case before making this bugreport was create a new imap-account for test a customer-problem and it selected "POP3". You can NEVER decide automatic using POP3 or IMAP with such mechanism as long the server provides both and the worst case is that the user has no plan what he uses

If you believe or not this is a problem everytime a user switches between different machines and different clients.

The first question for a new account has to be "imap with wizzard", "pop3 with wizzard" or "manually" without starting any automatism before

Comment 10

7 years ago
> The real problem with such things is that we create more and more users without
> knowing anything about their computer.

That's the *goal*, yes.

You may disagree with this goal, but it's the stated goal of the Thunderbird project to reach average users, and it's a simple fact that they don't know what "IMAP" is, nor want to know, and they are right.

> My case before making this bugreport was create a new imap-account for test a
> customer-problem and it selected "POP3". 

Discussed an answered. The current dialog is broken, but it's a technical bug, not a design problem.

Comment 11

7 years ago
(In reply to comment #4)
> (In reply to comment #3)
> 
>> Also you can use Mission Control Desktop AKA AutoConfig, with provided all
>> settings need for setup.
>> 
>> Fails to work reliably at this point...

> Can you elaborate on that on our enterprise mailing list at
> https://mail.mozilla.org/listinfo/tb-enterprise ?

Ok, I thought 'Mission Control Desktop AKA Autoconfig' was just some weird way of referring to the new account wizard... so, I'll retract my comment, and will be learning about this very interesting method for controlling large installations... thanks for the pointer Ludo...

Comment 12

7 years ago
(In reply to comment #6)
> > We are hosting > 100 domains
> 
> <https://developer.mozilla.org/en/Thunderbird/Autoconfiguration#Domain_hoster>
> 
> > it is not funny if a ip changes to edit every domain
> > only for have "pop3.domain.tld"
> 
> You could use DNS CNAME.

Isn't using CNAME records for MX pointers a big no-no according to the RFCs? I seem to recall this being made very clear on the postfix and spam-l lists.
(Reporter)

Comment 13

7 years ago
Please review the documentation
https://developer.mozilla.org/en/Thunderbird/Autoconfiguration#Domain_hoster

> You set up a web server bound to a physical IP address. 

Wrong

> This may be on the same machine as other web servers

True

> but you must dedicate one IP address to the autoconfig web server and the 
> web server must be configured to the content to any requested domain.
> In Apache terms

Wrong

> you must use an "ip-based virtual host", not a "name-based virtual host"

****!

The client does not know what type of host http://autoconfig.thelounge.net/mail/config-v1.1.xml and http://autoconfig.otherdomains.tld/ which are ServerAlias for 200 other domains is and has not to know

In the last hours i wrote a script which looks at dbmail which domains are active and refresh the xml-file, serveralias-list and creates "autoconfig"-CNAMEs in our dns-database to maintain this without any manual action in the future

Comment 14

7 years ago
> Bullshit!

Reindl, this is etiquette warning two.

A "review" of the documentation for an autoconfig server is offtopic here (as already said in comment 8).
And is unnecessary, as we have already discussed this in mail, and I already admitted that in unusual circumstances, other options are possible.

Comment 15

7 years ago
> Isn't using CNAME records for MX pointers a big no-no according to the RFCs?

I wasn't talking about CNAME for MX, but for the autoconfig server. And you talked about the POP server before. No MX anywhere.

Updated

7 years ago
Duplicate of this bug: 583701
Whiteboard: dupme
You need to log in before you can comment on or make changes to this bug.