Closed Bug 581984 Opened 10 years ago Closed 10 years ago

nsDOMQS.h:79:1: warning: "DOMCI_CASTABLE_INTERFACE" redefined

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 583727

People

(Reporter: dholbert, Unassigned)

References

Details

(Whiteboard: [build_warning])

Got this warning in an up-to-date m-c build from today.  I just noticed it for the first time in my build today -- I'm guessing it's due to something that changed in the past few days.

dom_quickstubs.cpp
In file included from dom_quickstubs.cpp:159:
../../../../../mozilla/js/src/xpconnect/src/nsDOMQS.h:79:1: warning: "DOMCI_CASTABLE_INTERFACE" redefined
In file included from ../../../../dist/include/nsContentUtils.h:59,
                 from ../../../../../mozilla/layout/base/nsPresContext.h:72,
                 from ../../../../../mozilla/layout/style/nsRuleNode.h:48,
                 from ../../../../../mozilla/layout/style/nsStyleSet.h:53,
                 from ../../../../../mozilla/content/base/src/nsDocument.h:98,
                 from dom_quickstubs.cpp:154:
../../../../dist/include/nsDOMClassInfoID.h:142:1: warning: this is the location of the previous definition
Component: DOM: Abstract Schemas → DOM
OS: Linux → All
Hardware: x86_64 → All
From glancing at a few build logs (for clobber builds only) over the past few days, I narrowed it to this regression range:

NO WARNING:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1279848271.1279856442.32573.gz
Built from changeset 6f9698905efb

HAS WARNING:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1279893331.1279898622.9814.gz
Built from changeset bcae411bc333

Regression pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6f9698905efb&tochange=bcae411bc333

In that range, Bug 566466 looks the most likely to be responsible.  Tentatively marking this as having been caused by that bug.
Blocks: 566466
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583727
Status: RESOLVED → VERIFIED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.