Proper licensing for including code from jQuery in Tab Candy?

RESOLVED FIXED

Status

mozilla.org
Licensing
P2
normal
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: iangilman, Assigned: gerv)

Tracking

Details

(Whiteboard: under legal review)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 460296 [details]
iq.js

Tab Candy has some utility code that includes modified portions of jQuery. JQuery's is dual-licensed under the MIT or GPL Version 2 licenses: 

http://jquery.org/license

We have two JavaScript files that contain these portions. Most of those files are original Mozilla code. What we've done is given them the standard MPL license block, but added: 

 * Some portions copied from:
 * jQuery JavaScript Library v1.4.2
 * http://jquery.com/
 * Copyright 2010, John Resig
 * Dual licensed under the MIT or GPL Version 2 licenses.
 * http://jquery.org/license

Is this correct?

The files are attached, if needed.
(Reporter)

Comment 1

8 years ago
Created attachment 460297 [details]
utils.js

Updated

8 years ago
Attachment #460296 - Attachment mime type: application/x-javascript → text/plain

Updated

8 years ago
Attachment #460297 - Attachment mime type: application/x-javascript → text/plain
Just for reference, looks like the tree already includes jQuery (albeit "as is" and also an older version, 1.3.2) as part of the feedback extension. This happened in bug 573079.
Since Gerv is going to be intermittently available the next six weeks, I'll take this myself. I'm coming back from vacation myself but will try to review it ASAP tomorrow.

Also reassigning to Legal for tracking/privilege purposes.
Assignee: gerv → lvilla
Group: legal
Status: NEW → ASSIGNED
Component: Licensing → Licensing
Product: mozilla.org → Legal
QA Contact: licensing → handerson
Whiteboard: under legal review
Version: other → unspecified
Duplicate of this bug: 582832
The use of the MPL block + additional text is best practice (though we're not pushing people hard to do it yet); thanks for taking that route. 

We would prefer the following additional text instead of what you guys proposed (similar, but slightly more explicit):

 * This file incorporates work from:
 * jQuery JavaScript Library v1.4.2
 * http://code.jquery.com/jquery-1.4.2.js
 * This incorporated work is covered by the following 
 * copyright and permission notice:
 * Copyright 2010, John Resig
 * Dual licensed under the MIT or GPL Version 2 licenses.
 * http://jquery.org/license

This gives someone looking at the file a very clear idea of where we got it from and what is going on.

Does this look acceptable to you?

Comment 6

8 years ago
This looks great, thanks Luis!
Closing, then; let me know if you have more questions.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Can we move this back to being a public bug now that Legal has given their opinion?

Comment 9

8 years ago
Good in my book.
Assignee: lvilla → gerv
Group: legal
Component: Licensing → Licensing
Product: Legal → mozilla.org
QA Contact: handerson → licensing
Version: unspecified → other

Comment 10

8 years ago
Also see bug 579729 (mention TabCandy's use of jQuery in about:license).
You need to log in before you can comment on or make changes to this bug.