bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Can't handle large ENVELOPE response from the server

VERIFIED INVALID

Status

MailNews Core
Networking: IMAP
P2
normal
VERIFIED INVALID
18 years ago
10 years ago

People

(Reporter: Wei-Lee Jamrog, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This test is running against Lotus Domino IMAP server.

Creating a new client account.  While client downlaoding the headers info, there
is one message that contains many many names in the To field. (probablly over
400 names.) This is a compay-wise email.  Client stop processing the rest of the
response.

here is a partial server log:
[0135:0005-0125] S:  * 282 FETCH (UID 282 RFC822.SIZE 17859 ENVELOPE ("Fri, 30
Oct 1998 11:59:14 -0500" "Lotus Admin systems announcements yesterday" ((NIL NIL
"Tim_Halvorsen/Iris%JAMROG" "iris.com")) ((NIL NIL "Tim_Halvorsen/Iris%JAMROG"
"iris.com")) ((NIL NIL "Tim_Halvorsen/Iris%JAMROG" "iris.com")) ((NIL NIL
"Tim_Halvorsen" "iris.com")(NIL NIL "Steven_Beckhardt" "iris.com")
.........  (many names deleted here...)
(NIL NIL "wjamrog" "iris.com")) NIL NIL NIL "<OF715CF7AD.701
[0135:0005-0125] S:  14F1D-ON852566AD.005CD332@iris.com>") BODY[HEADER.FIELDS
(Priority X-Priority References Newsgroups)] {4}<CRLF>
[0135:0005-0125] S:  <CRLF>
[0135:0005-0125] S:  <CRLF>
[0135:0005-0125] S:   FLAGS ())<CRLF>

Comment 1

18 years ago
.
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

18 years ago
accepting, though I suspect this might be a bug in the format of the envelope
response returned by the server - we can handle very large envelope responses.
Status: NEW → ASSIGNED
(Assignee)

Comment 3

18 years ago
*** Bug 57824 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

18 years ago
adding mail3 keyword
Keywords: mail3
(Assignee)

Comment 5

18 years ago
changing priorities
Priority: P3 → P2

Comment 6

18 years ago
is this the same as 56332
(Assignee)

Comment 7

18 years ago
maybe. Maybe not.

Comment 8

18 years ago
marking nsbeta1-. If it's a dup of 56332 then it'll get fixed.
Keywords: nsbeta1-

Comment 9

17 years ago
could a IMAP log of the problem be attached?

btw what's bug 56332 about? It's closed for the public...:)
(Assignee)

Comment 10

17 years ago
we don't use the envelope command anymore so this bug is no longer valid, if it
ever was. Bug 56332 was about a similar issue, but contained a test case which
was "confidential". It's verified fixed, so it's not interesting anymore, for
the same reason this bug should just be marked fixed: we don't use the envelope
command anymore.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 11

16 years ago
verified invalid
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.