Doing what I'll call a master repair of permissions makes Thunderbird Mail unusable crashing on start up (see logs).

RESOLVED DUPLICATE of bug 580156

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 580156
8 years ago
8 years ago

People

(Reporter: tom, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Thunderbird 3.1 downloaded 7-20-2010 (won't start can't give build numer)

More Testing Results: 
After using either OS X 10.5 start up disk to repair permissions starting from CD or using Onyx system utility to repair permissions, Thunderbird will not start. So repairing permissions hurt operation instead of helped it. Just running the simpler permission repair from mac disk utility does not seem to do this. Somehow Thunderbird email is flaking out when either apple or other complete permission repairs programs are run. No other programs on my system were affected. About 20 other programs ran fine from the doc.

Reproducible: Always

Steps to Reproduce:
1. run master permission repair from mac os x 10.5.8 or from onyx system utilities.
2. start Thunderbird and it crashes making two logs which I will upload
3.
Actual Results:  
Thunderbird crashes on start up after a complete permissions repair.

Expected Results:  
None, complete disk permissions repair should have no affect or help operation.
(Reporter)

Comment 1

8 years ago
See bug 580156 for other permissions comment. In this case ignore would restart Thunderbird Mail but neither ignore nor continue from the crash reporters will make it start, it will not start.
(Reporter)

Comment 2

8 years ago
Created attachment 460485 [details]
Crashreporter log as rtf

Start up after master complete permissions rebuild.
(Reporter)

Comment 3

8 years ago
Created attachment 460486 [details]
Thunberbird bin (can't remember if this or other file came up first asking for ignore or continue).

Updated

8 years ago
Attachment #460485 - Attachment mime type: text/rtf → text/plain

Updated

8 years ago
Attachment #460486 - Attachment mime type: text/rtf → text/plain

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 580156
(Reporter)

Comment 5

8 years ago
For the above see bug 460484 the other number was in error.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

8 years ago
contact me on irc. don't touch bugs until you do.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 580156
(Reporter)

Comment 7

8 years ago
Restoring old Thunderbird files such as plist and profile then running mac os disk fix permissions rebuild does not help. Time Machine backup that are restored just do not work.
You need to log in before you can comment on or make changes to this bug.