MDC fulltext search broken (fails on any search words, not working)

VERIFIED FIXED

Status

Mozilla Developer Network
Wiki pages
--
critical
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: Thomas D., Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
STR

1 https://developer.mozilla.org
2 type simple search term (e.g. "alert", without quotation marks) into search box (upper-right corner)

Actual

- this search is executed:
https://developer.mozilla.org/Special:Search?search=alert&type=fulltext&go=Search
- no results, error message  "Your search query type contains characters which need to be escaped. See this FAQ for more information."
- which is nonsense, as there are no special characters in the word "alert"

Expected

- show results as you did until yesterday:
results page with linkified titles like (e.g. for the search term "type")
type in en/XUL/Property
type in en/XPCOM Interface Reference/nsISupportsPrimitive

This used to work perfectly and stopped working today.
(Reporter)

Updated

8 years ago
Severity: normal → major
I can confirm this. What the...
Component: Docs Platform → Website
OS: Windows XP → All
QA Contact: docs-platform → website
Hardware: x86 → All
Blocks: 578779

Updated

8 years ago
No longer blocks: 578779
Were there any changes to Dekiwiki? It supposedly incorporates Lucene, so I assume some change somewhere has triggered this.

If the search index itself is broken for some reason, recreating/reindexing might help. (Keep in mind though I know nothing about Lucene).

Do we have support with Mindtouch? If so, ask them for advice, please.
We have made no changes to the Deki install. I'll start a rebuild of the search index; it might be borked.
How long should the index rebuild take?  It's been 3 days and searching still isn't working.
Severity: major → critical
Would be great if we can fix this bug as soon as possible. Having no search results available makes it nearly impossible to use our documentation. Personally I'm blocked because I can't find the information I need.
It would be nice if this could be fixed, but until it is, I'd recommend using Google's site search as a work around.  Simple use the search term "site:developer.mozilla.org" plus the search text.

Comment 7

8 years ago
Apologize for being a me too on this one, but is there any update?
I've seen more complaints about this on IRC now.

Why has search on DevMo been broken for over a week, and who needs to own this to get it fixed?
This is in work. Something is going wrong with the lucene indexer and IT has not been able to identify the problem. MindTouch is investigating; we have a ticket open with them.
Depends on: 582740
Ah, thanks for adding the 582740 dep. Carry on!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

8 years ago
(In reply to comment #11)
> Verified FIXED

Thank you!
(Assignee)

Updated

6 years ago
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.