Going to full (F11) screen hides tabs

RESOLVED DUPLICATE of bug 587209

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 587209
8 years ago
8 years ago

People

(Reporter: Erlo Haugen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100724 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100724 Minefield/4.0b3pre

When pressing F11, the browser goes into full screen mode, but after a second the browserwindow grows too large for the screen, the result being that the tabs and half the address filed are hidden.

Reproducible: Always

Steps to Reproduce:
1.Open a web page
2.Press F11
3.
Is this behavior different from previous versions, say 3.6.8? Full screen browsing is supposed to display just the content. If you hover over the top of the screen, your controls should come back.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Is this behavior different from previous versions, say 3.6.8? Full screen
> browsing is supposed to display just the content. If you hover over the top of
> the screen, your controls should come back.

I am not able to launch my previous FF, so I can't tell.
The controls don't come back when I hover to the top of the screen.
You say, that when you move your mouse to the top border of you screen doesn't show the toolbars? Have you tried it already in Safe Mode or a fresh profile? Is that reproducible then? Would be great if you could create a screencast with Jing (http://jingproject.com/).

Otherwise it is expected behavior that the toolbars gets hidden by default. You will have to disable it via the context menu of the toolbars in fullscreen mode.

Can't see anything wrong on my XP box.

Comment 4

8 years ago
found this bug in 2010-08-14 nightly build (FF 4.0b4pre). I did not check in previous versions. Screenshot attached.

Comment 5

8 years ago
Created attachment 466034 [details]
Improper Fullscreen screencap

screencap of improper fullscreen in 20100814 nightly build FF4.0b4pre

Comment 6

8 years ago
(In reply to comment #5)
Forgot to mention:
Tested: 20100814 Nightly build. Clean profile, fresh install.
Tested on: Windows 7 professional

Updated

8 years ago
Depends on: 575870

Comment 7

8 years ago
Update: I just noticed that this happens only when the menu bar is collapsed into the Firefox (or Minefield for nightly builds) button. When the full menu bar is visible, fullscreen works as it should.

As indicated by Dão Gottwald, this seems to be an issue from bug #575870 and how the titlebar and caption buttons are implemented and seems to be windows specific (though comments in #575870 indicate it is vista and win 7).

Could someone check if this bug appears on a non-microsoft OS?

Comment 8

8 years ago
I just checked the nightly builds and this bug was not present in the 4.0 branch until 2010-08-13.

Comment 9

8 years ago
Note to developers:
I went through bug #575870, and I think some code submitted on 2010-08-12 or 13 caused the 2010-08-13 nightly build to have this. 

Is there any way to track http://hg.mozilla.org/mozilla-central/ for changes made during this time? (I usu. use SVN and am not familiar with mercurials).

Comment 10

8 years ago
Is bug 582231 a dupe of this? (They have the same screen shot.) This might be related to tab candy.

Comment 11

8 years ago
(In reply to comment #10)
> Is bug 582231 a dupe of this? (They have the same screen shot.) This might be
> related to tab candy.

Doh, I meant bug 587209, which is now fixed. This should be too. WFM beta5pre.

Updated

8 years ago
No longer depends on: 575870

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587209
You need to log in before you can comment on or make changes to this bug.