With Option "Fetch Headers Only" and downloading content of a Header Only Message can lost the Message, with uncaught exception: ... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) ..."

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
9 years ago
a year ago

People

(Reporter: heicore1, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupme])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.99 Safari/533.4
Build Identifier: Thunderbird 3.0.6

I Have the option "Fetch Header Only" on. When ich download my Mails I have only the Header in the List. When I now Click on the Link, in the Mail, to download the Content of the Mail, sometimes the Mail is not longer display in the List.
It looks like the process is this:
1. Thunderbird delete the old - Header Only - Message 
2. Thunderbird reload the Message complete

Sometimes it looks like that Thunderbird does not do the Step 2. Thunderbird delete the Message and don't reload the Message from the Server. The Message is already aviable on the Server but don't displayed in the List.

I Use GMX for my Mails.

Reproducible: Sometimes

Steps to Reproduce:
Not aviable

Updated

9 years ago
Whiteboard: dupme

Comment 1

8 years ago
I've got the sameproblem here, using the latest version of thunderbird with Lightning installed. Also using GMX for my mails. For me, this is a reproduceable bug as every mail gets deleted after clicking "Download complete mail", from Inbox, Trash, and every other folder.
At GMX-Webinterface itself the mails stay marked as "unread" even after they were downloaded.

Comment 2

8 years ago
(In reply to comment #1)
> I've got the sameproblem here, using the latest version of thunderbird with
> Lightning installed. Also using GMX for my mails. For me, this is a
> reproduceable bug as every mail gets deleted after clicking "Download complete
> mail", from Inbox, Trash, and every other folder.
> At GMX-Webinterface itself the mails stay marked as "unread" even after they
> were downloaded.

Ah, forgot:
Using Windows 7 Ultimate, x86 machine. Mails are received via pop3. 
Thunderbird Version Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.11) Gecko/20101013 Lightning/1.0b2 Thunderbird/3.1.5

Comment 3

8 years ago
Output of Thunderbird-Errorconsole:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMessenger.msgHdrFromURI]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/mailWindow.js :: anonymous :: line 440"  data: no]
Duplicate of this bug: 610147
Duplicate of this bug: 618226
(correct spelling is "Fetch Headers Only")

Do you still see this issue?
(not sure what I would dup this to
Flags: needinfo?(purejunk11)
Flags: needinfo?(heicore1)
Flags: needinfo?(PhilippMeyer2)
Flags: needinfo?(Eva.Luation)
Keywords: dataloss
Summary: With Option "Fetch Header Only" and downloading content of a Header Only Message can lost the Message → With Option "Fetch Headers Only" and downloading content of a Header Only Message can lost the Message, with uncaught exception: ... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) ..."
Whiteboard: dupme → [closeme 2017-08-25][dupme]

Comment 7

2 years ago
Wayne, I don't remember ever having the issue. If I did, I guess the problem went away.  :-)
Flags: needinfo?(purejunk11)

Comment 8

a year ago
Resolved per whiteboard and Comment 7
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(heicore1)
Flags: needinfo?(PhilippMeyer2)
Flags: needinfo?(Eva.Luation)
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2017-08-25][dupme] → [dupme]
You need to log in before you can comment on or make changes to this bug.