If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Make sure video controls get click events

RESOLVED DUPLICATE of bug 1032246

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1032246
7 years ago
3 years ago

People

(Reporter: micmon, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
On the WARMCSS┬╣ demo, click one of the videos on the bottom to make it large. Now right-click and show the controls. Try to seek to the end. It won't work because something intercepts the click and instead makes the video small again.

[1] http://demos.hacks.mozilla.org/openweb/WARMCSS/
(Reporter)

Comment 1

7 years ago
Tested on a post-beta2 minefield on Linux, but I guess it affects other platforms as well.
OS: Linux → All

Updated

7 years ago
Duplicate of this bug: 582488

Comment 3

7 years ago
It affected on Windows 7 as well.
Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100727 Minefield/4.0b3pre ID:20100727041441
There's a capturing click handler set on an ancestor of the video.  So that handler should fire before the controls are triggered.  What's the bug, exactly?
(Reporter)

Comment 5

7 years ago
(In reply to comment #4)
> There's a capturing click handler set on an ancestor of the video.  So that
> handler should fire before the controls are triggered.  What's the bug,
> exactly?

Maybe the real "bug" is with the page but there will always be buggy pages and I still want to be able to use the seek function in such a case.

Comment 6

7 years ago
Video controls works as expected on  Opera 10.6 .
(Reporter)

Comment 7

7 years ago
Yep, works on Chrome as well.
> I still want to be able to use the seek function in such a case.

That's what disabling script is for, no?  I mean... a page could navigate you to some random url on any click on any object in the page; it'd just be a buggy page, but you wouldn't be able to seek in the video on it.  And that seems like the right behavior if that's what a page is doing.

Do Chrome and Opera not deliver DOM events to the web page at all when you click on the controls?  That would seem like a pretty serious bug to me.
(Reporter)

Comment 9

7 years ago
(In reply to comment #8)
> Do Chrome and Opera not deliver DOM events to the web page at all when you
> click on the controls?  That would seem like a pretty serious bug to me.

I did only test seeking before. I can use the volume button/slider just fine on Chrome but pressing play/pause does toggle the state AND moves the window. So, very irritating
Yeah, sounds like the event delivery in Chrome is just buggy.
Per the bits of spec quoted in bug 1032246, I'm pretty sure this is a bug in our video control implementation. Duping there because it has less confusion and more detail (and because I expect this to be fixable within the toolkit binding... although I could obviously be wrong)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1032246
You need to log in before you can comment on or make changes to this bug.