Printing broken on Carbon

VERIFIED FIXED in mozilla0.9.3

Status

()

P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: mikepinkerton, Assigned: mikepinkerton)

Tracking

Trunk
mozilla0.9.3
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: OSX++, [PDT+], needs r/sr)

Attachments

(1 attachment)

(Assignee)

Description

18 years ago
The MacOS printing APIs were obsoleted in Carbon. We need to rewrite printing to
use the new APIs.
(Assignee)

Comment 1

18 years ago
*** Bug 58255 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Keywords: mozilla0.9

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Assignee)

Comment 2

18 years ago
dcone, this is needed in the mozilla1.0 timeframe, OSX is a tier one platform
for the next release.

Comment 3

18 years ago
spam : changing qa to sujay (new qa contact for Printing)
QA Contact: shrir → sujay

Comment 4

18 years ago
With Mozilla 0.9 being Carbonated I believe it's time to bring this bug Back From 
the Future
nominating for dogfood (from sdagley's list of bugs that are good candidates for 
our next release) 
Keywords: nsdogfood
Keywords: nsCatFood
Keywords: nsdogfood
(Assignee)

Comment 6

18 years ago
printing is dogfood.
Keywords: nsbeta1, nsdogfood

Comment 7

18 years ago
I already did much of this work. What's missing?

Comment 8

18 years ago
dogfood+, therefore removing catfood.  What's required to complete the fix?
Keywords: nsCatFood, nsdogfood → nsdogfood+

Updated

18 years ago
Whiteboard: OSX+
(Assignee)

Comment 9

18 years ago
beta stopper. printing doesn't work at all on m6y 6/5 osx build.
Whiteboard: OSX+ → OSX++
Target Milestone: Future → ---

Updated

18 years ago
Target Milestone: --- → mozilla0.9.3

Comment 10

18 years ago
Probably falls under the realm of the last comment, but the 'Preview' button
doesn't work in the Print dialog either...
(Assignee)

Comment 11

18 years ago
*kick*
Assignee: dcone → sdagley
Status: ASSIGNED → NEW
(Assignee)

Updated

18 years ago
Summary: Printing needs to be rewritten for Carbon → Printing broken on Carbon
Whiteboard: OSX++ → OSX++, PDT+

Updated

18 years ago
Whiteboard: OSX++, PDT+ → OSX++, [PDT+]

Updated

18 years ago
Keywords: mozilla0.9 → nsBranch

Comment 12

18 years ago
Steve, this is PDT+ bug. Tomorrow, on Tuesday, we'll try to build the first RTM
candidate. It would be good, if this could be checked in ASAP.
(Assignee)

Comment 13

18 years ago
i have a fix to get it to print (dcone broke it with the print options landing, 
ahem), and a fix to a memory leak on os9 and osx (nsCOMPtr is your friend, ahem), 
but it only prints one time.

I'm doing a debug build now to figure it out. taking.
Assignee: sdagley → pinkerton

Comment 14

17 years ago
*** Bug 89728 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Whiteboard: OSX++, [PDT+] → OSX++, [PDT+], investigating
(Assignee)

Comment 15

17 years ago
Created attachment 42221 [details] [diff] [review]
[patch] fix printing on osx and a leak on 9/X
(Assignee)

Comment 16

17 years ago
patch attached that fixes printing on carbon. We were leaking the devContextSpec 
on both 9 and X and that had to be fixed for carbon. When this is closed, i'll 
open a new bug for dcone to implement the print options he stubbed out for 
carbon.

needing r/sr.
Status: NEW → ASSIGNED
Whiteboard: OSX++, [PDT+], investigating → OSX++, [PDT+], needs r/sr

Comment 17

17 years ago
sr=sfraser

Comment 18

17 years ago
r=sdagley
(Assignee)

Comment 19

17 years ago
fix landed on trunk and branch. we need to get some classic macos9 coverage on 
this just to be safe since i fixed a leak there that might cause code to be 
executed that wasn't being called.
(Assignee)

Comment 20

17 years ago
.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 21

17 years ago
bug to implement carbon print options given to dcone.

http://bugzilla.mozilla.org/show_bug.cgi?id=90751

Comment 22

17 years ago
Mike, can you please verify this one and mark VERIFIED-FIXED?

I don't have access to a machine with Mac OSX..

Also cc'ing Chris Petersen
(Assignee)

Comment 23

17 years ago
since part of the fix involves macos9, also verify that printing on os9 is ok and 
doesn't do anything weird. try printing two times just to make sure.

Comment 24

17 years ago
Marking verified in the 20010716 builds. Checked in Mac OS X 10.0.4 and OS 9.1.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.