Move the Download Manager into a tab (about: page)

RESOLVED DUPLICATE of bug 697359

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED DUPLICATE of bug 697359
8 years ago
7 years ago

People

(Reporter: Stefan Vallaster, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

Emphasizing on the new UI style with tabs in focus, it would be a pleasure that the download manager opens as a new tab (and not as a new window), maybe it could be manaaged to open the download manager tab as a app tab (not sure if that would some confuse the users, who are using app tabs)

Reproducible: Always
(Reporter)

Updated

8 years ago
OS: Windows 7 → All
Hardware: x86_64 → All

Updated

8 years ago
Component: Tabbed Browser → General
QA Contact: tabbed.browser → general
The download manager will not use a tab but a notification like style. Alex, I'm sure you know the bug #.
And the Downloadhistory will be integrated into the Library (Bug 564900), what itself will be made available as a Tab (waiting on Bug 130078) like the new AOM later on.
Shawn, beside bug 564934 do we wanna move the download manager into a tab in the future?
(In reply to comment #3)
> Shawn, beside bug 564934 do we wanna move the download manager into a tab in
> the future?
You should ask the user experience team ;)
Keywords: uiwanted
(In reply to comment #3)
Yes, please!
Confirming based on UX feedback and moving into the appropriate component.
Status: UNCONFIRMED → NEW
Component: General → Download Manager
Ever confirmed: true
Keywords: uiwanted
Product: Firefox → Toolkit
QA Contact: general → download.manager
Summary: Download Manager Tab → Move the Download Manager into a tab (about: page)

Updated

8 years ago
Blocks: 584942
Duplicate of this bug: 620228

Comment 8

7 years ago
just an opption,anyone who doesn't like open-in-tab can still open it in window, open-in-tab can use the tab icon to show donwload progress, I don't suppose you guys will never find a way to show donwload progress since removed the status-bar? Chrome even open a large bar for it, users have the needs!
(In reply to comment #8)
> just an opption,anyone who doesn't like open-in-tab can still open it in
> window, open-in-tab can use the tab icon to show donwload progress, I don't
> suppose you guys will never find a way to show donwload progress since removed
> the status-bar? Chrome even open a large bar for it, users have the needs!

The plan is to make it part of the panel, but it didn't make it in time for 4.0.

See:
http://limi.net/media/sketchdownloadsround.png

And for full background:
http://limi.net/articles/improving-firefox-downloads

Updated

7 years ago
No longer blocks: 584942

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 697359
You need to log in before you can comment on or make changes to this bug.