[k] Logging in to Kitsune from Minefield (4.0b3pre) doesn't create session cookie

RESOLVED WORKSFORME

Status

support.mozilla.org
General
P1
normal
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: jsocol, Unassigned)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
1) Log out, clear cookies, etc.
2) Start on https://support-stage.mozilla.com/en-US/questions
3) Click "Log in" at the top.
4) Log in with valid credentials. (Screwing up the credentials confuses Tiki's "where do I go next" logic.)

Should be logged in, but I am not.

Here are the relevant requests/headers:

----------------------------------------------------------
https://support-stage.mozilla.com/tiki-login.php

POST /tiki-login.php HTTP/1.1
Host: support-stage.mozilla.com
User-Agent: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100728 Minefield/4.0b3pre
Referer: https://support-stage.mozilla.com/tiki-login_scr.php?locale=
Cookie: SUMOv1=f4oe9chhl1m2jsc2c3261quu03; WT_FPC=id=2f926fef02f9e4b45fa1280312915144:lv=1280312915144:ss=1280312915144; wtspl=896264


HTTP/1.1 302 Found
Date: Wed, 28 Jul 2010 14:26:56 GMT
Set-Cookie: SUMOloggedin=true
Location: https://support-stage.mozilla.com/en-US/questions


----------------------------------------------------------
https://support-stage.mozilla.com/en-US/questions

GET /en-US/questions HTTP/1.1
Host: support-stage.mozilla.com
User-Agent: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100728 Minefield/4.0b3pre
Referer: https://support-stage.mozilla.com/tiki-login_scr.php?locale=
Cookie: SUMOv1=f4oe9chhl1m2jsc2c3261quu03; WT_FPC=id=2f926fef02f9e4b45fa1280312915144:lv=1280312915144:ss=1280312915144; wtspl=896264; SUMOloggedin=true

HTTP/1.1 200 OK
Date: Wed, 28 Jul 2010 14:26:56 GMT
Content-Type: text/html; charset=utf-8

----------------------------------------------------------

The last HTTP/1.1 200 OK should have a Set-Cookie header. I can reproduce this 100% of the time on nightlies from 7/27 and 7/28 on Windows 7, but not on 3.6.8. If other people could check other versions/browsers/OSes?

Security-group until all the session IDs above age out.
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
These bugs are all resolved, so I'm removing the security flag from them.
Group: websites-security
You need to log in before you can comment on or make changes to this bug.