Bump application.ini MinVersion to 1.9.2.0

RESOLVED FIXED in 0.7

Status

Add-on SDK
General
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: adw, Assigned: adw)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 460897 [details] [diff] [review]
patch

Jetpack requires Gecko 1.9.2 (and install.rdf does list 3.6 as the Firefox minVersion), but application.ini still lists 1.9.1 as MinVersion, causing errors when people use cfx with an old XULRunner like this person did:

http://groups.google.com/group/mozilla-labs-jetpack/browse_thread/thread/4fe4e0b726a24b8b

BTW, separately I tried to update MaxVersion to 2.0b3pre, but Minefield immediately exits after it starts.  Don't know what's going on there.
Attachment #460897 - Flags: review?(avarma)

Comment 1

8 years ago
(In reply to comment #0)
> BTW, separately I tried to update MaxVersion to 2.0b3pre, but Minefield
> immediately exits after it starts.  Don't know what's going on there.

I wonder if this has something to do with bug 568691... it could be the case that the harness.js code is never loaded, and therefore XULRunner thinks it has nothing to live for and quits immediately.

If so, fixing this would probably mean adding a chrome.manifest that includes data about harness.js or something.

Comment 2

8 years ago
Comment on attachment 460897 [details] [diff] [review]
patch

Looks good!
Attachment #460897 - Flags: review?(avarma) → review+
(Assignee)

Comment 3

8 years ago
Hmm, I should probably go back several nightlies until I reach one that doesn't work.

Thanks for the quick review, pushed:
http://hg.mozilla.org/labs/jetpack-sdk/rev/b4dcb16e16bd
Assignee: nobody → adw
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: -- → 0.7
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.