RFE - PNG alpha with 100% transparency is not rendered 100% transparent. [gfx][png]

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: mgalli, Assigned: dcone)

Tracking

Trunk
Future
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Some help is needed here to certify. 
Tested with older versions and Gecko/20001023, win98.

From long time I saw PNG images with portions 100% transparent (in the alpha 
channel) that over some background colors is possible to note that these images 
are not rendered completelly 100% transparent (in the 100% transp areas).

http://www.libpng.org/pub/png/pngs-img.html

Note the toucan images. If you have a notebook TFT display, look from the bottom 
 - is easy to note :-). When background are light colors or very dark it's 
difficult to see. With this test that is a green background I can see. In a lot 
of other pages with PNG just change the background for something like #aaaaaa 
and you will note.

Comment 1

18 years ago
Maybe a Windows thing?  They look pretty damn transparent on Linux 2000-10-27
nightly trunk build, XFree86 DRI CVS snapshot, 16-bit color.
Summary: RFE - PNG alpha with 100% transparency is not rendered 100% transparent. → RFE - PNG alpha with 100% transparency is not rendered 100% transparent.
(Reporter)

Comment 2

18 years ago
Tested with Linux, 2000-09-29 Netscape 6 Build just to verify behavior with
Linux. Agreed - pretty and 100% transparent (for the eyes).

Comment 3

18 years ago
Tested the actual transparency with a graphics application. All of the toucan 
images transparencies are correct here on Windows 2000 (2000102905) trunk bits.

Comment 4

18 years ago
Aha! Note the user mentions a TFT screen. And what's different about a TFT
screen compared with most decent hardware these days? 16bpp frame buffer!

This could very well be a different rendering path for images (no matter whether
transparent) and page backgrounds. On 24bpp it all comes out in the wash, but on
16bpp or 8bpp you might see tiny but perceptible differences.

Owner/ testers - tell your OS or Windowing system to use 16bpp, and repeat the
experiments you tried earlier. The differences may need VERY GOOD eye sight, but
they are probably there.

Since this behaviour won't be seen on decent display hardware it is only a minor
niggle and shouldn't be corrected while engineer resources are needed elsewhere.
Note that WinIE and NS4x won't display the transparency anyway so we're already
ahead.
(Reporter)

Comment 5

18 years ago
Agreed, this may be a behavior in the 65K color mode. Tests welcome to help 
confirming this bug. If this is a bug in the nightly build I agreed that this is 
minor. Also that is an easy fix. 

Comment 6

18 years ago
Please check 51179 for another possible cause of the symptoms in Marcio's
original bug report. Here I cannot _see_ the problem, but a screenshot and an
image editor's "eyedropper" tool makes it obvious in short order.
The TFT 16bpp thing would exacerbate the problem in 51179 if I'm right.

Comment 7

18 years ago
umm.. Win98 desktop. pIII 550MHz Moz Build: 2000121508
16bit colour - Toucans background not 100% transparent.
24/32bit colour - Toucans background transparent.
If it will help I can throw in some screen shots of the difference?

However my display was set to 16bit by default.. would be nice if 16bit would 
show transparency.. is this possible, or imporrible due to the capabilites of 
16bit display?
Anyway.. I can see what the reporter saw, so I am confirming. However I think 
this could be a duplicate of bug 19283 - that is marked fixed, so I'm not too 
sure what's going on.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

18 years ago
QA Contact: petersen → tpreston
Reassigning to dcone.
Assignee: kmcclusk → dcone

Comment 9

18 years ago
Using Mozilla 0.7 on Linux, you can see transparent PNG images aren't 100%
transparent when you stack them.  The more you stack, the more apparent it
becomes.  Will attach a screen snapshot of this behavior.

Comment 10

18 years ago
Created attachment 25360 [details]
Linux example with stacked transparent PNG images

Comment 11

18 years ago
The images in the attached example havea visual depth of 16. 
(Reporter)

Comment 12

18 years ago
staked transp png was a great idea!!
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: RFE - PNG alpha with 100% transparency is not rendered 100% transparent. → RFE - PNG alpha with 100% transparency is not rendered 100% transparent. [gfx][png]
Target Milestone: --- → Future

Comment 13

18 years ago
http://Games.GadgetScope.com/ - View in 16 bit color
Transparent areas are not being rendered properly - instead there almost seems
to be an ordered dither occuring that isn't necessary. Looks OK in 32 bit color.

Build: 2001062004 Win98 + 3dfx Voodoo3 3000 800x600x16

Comment 14

18 years ago
Created attachment 39539 [details]
Screenshot of incorrect rendering of PNG transparency

Comment 15

17 years ago
WFM 2002022103/WinXP@16bbp
neither do the parrots look wrong (tested by enhancing a screenshots contrast
with the GIMP) nor does http://games.gadgetscope.com/ show the errors displayed
by the screenshot.
anyone still seeing thist? otherwise WFM?
(Assignee)

Comment 16

17 years ago
Marking works for me.. if anyone see's the problem.. reopen. and describe exact 
symptoms.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 17

17 years ago
Mass removing self from CC list.

Comment 18

17 years ago
Now I feel sumb because I have to add back. Sorry for the spam.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.