automatic compacting of folders causes Message content missing (blank) or folder view resets

RESOLVED DUPLICATE of bug 367689

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 367689
7 years ago
6 years ago

People

(Reporter: Teo V., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-gb; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; sv-SE; rv:1.9.1.11) Gecko/20100711 Thunderbird/3.0.6

I've noted this tendency for things to go a bit awry when TB does its automatic compaction of folders in my RSS feeds and local folders, i.e. removes deleted messages to save space.

The problem manifests itself when viewing RSS feeds by the automatic compaction starting, and when it's done, the folder view jumps and a blank page is displayed instead of the item you were viewing when the compaction started.

The problem manifests itself when viewing NNTP/News by the automatic compaction starting, and if you happen to be retrieving a message when it happens, none of its contents are shown, and restart of TB is necessary to be able to see the message, not even "View Source" will display it.

And (I don't know if this is related), sometimes the progress bar on the lower right hand of the status bar indicates something in progress which never completes (stays there no matter what). Disappears if TB is restarted.

Plugins I use:

* Adblock Plus
* British English Dictionary
* Enigmail
* Manually Sort Folders
* Minimize to Tray
* Profile Switcher
* Svensk Ordlista (Swedish Dictionary)
* Thunderplunger
* United States English Dictionary

Reproducible: Sometimes
Does it happen without any add-ons enabled ?
(Reporter)

Comment 2

7 years ago
Just tried safe mode and manually compacted the folders (Right Click->Compact)
on my RSS Feed collection.
Problem remains, folder view is reset from the article/message you were looking at to a blank page in the message pane(l).

Comment 3

7 years ago
I can confirm this happens to me as well. Running on Windows 7 Ultimate x64 with a fresh install of the OS, and TB 3.1.9. The only add on installed is CompactHeaders 1.2.4. If I have clicked into the body of the message and hit delete it behaves as expected and loads the next message UNTIL it compacts the folder (as indicated by the compacting message in the status bar). At that point the next message doesn't load however the next message IS flagged as read. Something like this...

Click the folder in the navigation pane on the left.
Click the first message header in the listing at the top
Click the body of the message (allowing me to scroll using the keyboard)
Hit delete. Next message loads.
Hit delete. Next message loads.
Repeat for a while
Hit delete. Wait for a while. Notice message isn't loading.
Look in bottom status bar. See message about compacting.
Click first message header in the listing at the top (now flagged as read)
Repeat process.
(In reply to comment #3)
> Hit delete. Next message loads.
> Hit delete. Next message loads.
> Repeat for a while
> Hit delete. Wait for a while. Notice message isn't loading.
> Look in bottom status bar. See message about compacting.
> Click first message header in the listing at the top (now flagged as read)
> Repeat process.

Which occurs first? 
> (a) Notice message isn't loading, after "Hit delete. Wait for a while"
> (b) Look in bottom status bar. See message about compacting.
If (a) occurs first and (b) occurs after a while, you may be looking phenomenon of bug 612279(see also bug 533499) by multiple/concecutive delete. As contention in message pane refresh by multiple tasks(for deleted mail, and for next mail), blank display may happen at message pane. 

To see "auto-compact" is relevant or not, set mail.purge.ask=true via Config Editor and restart Tb. Dialog before auto-compact is shown, and you can cancel auto-compact. Never check "Do it always ..." like option at the dialog. That will change mail.purge.ask to false, so you need to manually set mail.purge.ask=true again and need to restart Tb again.

If auto-compact is relevant to your problem, problem like bug 496892(local mail folder case, see also Dependency tree for meta Bug 498274) may happen on RSS, because "delete" and "compact" can happen simultaneously in your case if interval between (a) and (b) is not sufficiently long.

If auto-compact=on and mail.purge.ask=false, it's hard to know when Compact is invoked for the relevant folder. If you try to do duplication test of this bug, please do as bug opener did first - Simply execute manual Compact Folder for the relevant folder only. auto-compact=off is preferable, to rule out "contention" or "interfering each other" between auto-compact and manual Compact Folder.

Matt Neimeyer, can you reproduce problem with "simple manual compact folder of RSS"?
I also saw blank display at thread pane and/or message pane after Compact Folder of local mail folder or IMAP folder with old Tb versions. But I couldn't observe it on local mail folder and IMAP folder with Tb 3.1.x.
  0. A mail selected and shown at message pane normally.
  1. Compact Folder
  2. After end of compact, thread pane/message pane is cleared,
     then thread pane is painted, previously selected mail is highlighted,
     and the selected message is shown at message pane as expected.
  Each step is not so fast, so it can be observed if not so small folder.
RSS case may be different, because server access may happen upon Compact(perhaps via HTTP).

Comment 5

7 years ago
> Which occurs first?

It basically goes like this...

Read Item 1
Delete Item 1 Using Delete Key
Pause / Loading Item 2
Read Item 2
Delete Item 2 Using Delete Key
Pause / Loading Item 3
Read Item 3
Delete Item 3 Using Delete Key
Pause / Loading Item 4
Pause
Pause
Pause (Mentally, Hey this is taking too long)
Look at Status bar. See message about compacting.

> Can you reproduce the problem with a "simple manual compact folder of RSS?"

Your item 2 is not what I'm experiencing. What's happening to me is that nothing ever loads no matter how long I wait. If I hit "N" I am taken to Item 5 (in the above listing) and item 4 is toggled to a read status even though it never showed up on the screen. I can also click Item 4 and it will show up.

I don't think I've ever observed this behavor when using a mouse to navigate. Additionally it doesn't happen if I manually compact (but I wouldn't expect it to because the item is already loaded at that point and this only seems to happen when Loading and Compacting are happening at the same time).

Comment 6

6 years ago
this is a duplicate.
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
Summary: Problems during automatic compacting of folders: Message content missing (blank) or folder view resets to something else than the message you were viewing when compaction began. → automatic compacting of folders causes Message content missing (blank) or folder view resets
Whiteboard: dupeme

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 367689
Whiteboard: dupeme

Comment 8

6 years ago
I was bounced here from bug 702893.  It appeared to be a duplicate of the issues raised here, correctly so, it appears.  Thanks to whoever did so.

I have one comment which may or may not be significant...
The folders that would "empty," or more properly, hide contents, when an auto-compact occurs (they remain in message database)seem to only occur if I am accessing some of the messages in that folder -- usually in a house-cleaning operation weeding out spam and other unwanted mail which obviously involves some considerable deleting.  Only that folder loses its content, none of the others in the mail database and none of the sub-folders in that folder.  The deletion only seems to occur while this weeding operation is in progress.  I do not remember "losing" content purely spontaneously.

One other side comment.  Several days after finding an emptied folder, when starting up my system for the day, lo and behold, at least some of the messages -- maybe all, I don't know -- reappeared.  Several system shutdowns and startups had taken place in the interim.

I'm still using the system.  If any further observations arise, I'll post another note.

GW Riedeman
You need to log in before you can comment on or make changes to this bug.