Last Comment Bug 582818 - [OGL] Enable GLES compositing by default on Android
: [OGL] Enable GLES compositing by default on Android
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: ---
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
Mentors:
Depends on: 130078 opengl-mobile
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 18:10 PDT by Stuart Parmenter
Modified: 2014-04-25 15:17 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+


Attachments
patch (557 bytes, patch)
2010-12-15 11:30 PST, Brad Lassey [:blassey] (use needinfo?)
mark.finkle: review+
Details | Diff | Splinter Review

Description Stuart Parmenter 2010-07-28 18:10:16 PDT
Right now we're using software compositing, but should turn on hardware acceleration.
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2010-12-15 11:30:38 PST
Created attachment 497835 [details] [diff] [review]
patch
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2010-12-15 11:40:11 PST
Comment on attachment 497835 [details] [diff] [review]
patch

Are we sure this is ready? All other patches we care about have landed?
Comment 3 Jeff Muizelaar [:jrmuizel] 2010-12-15 12:23:07 PST
I don't know of any major problems preventing this.

It would be nice to get bug 604101 in first, but I don't think it's necessary.
Comment 4 Vladimir Vukicevic [:vlad] [:vladv] 2010-12-15 12:37:11 PST
Only other thing I would suggest is implementing GfxInfo and a blocklist on Android; there are a number of places where we'll likely see various rendering bugs due to issues that are outside of our control.  But that doesn't need to block this.
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2010-12-15 15:37:05 PST
pushed https://hg.mozilla.org/mobile-browser/rev/d5cb2a1af3bf
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2010-12-15 17:32:52 PST
I had to exclude this change for Maemo. It was crashing the Talos machines:
http://hg.mozilla.org/mobile-browser/rev/ced5e2db6996
Comment 7 Steffen Wilberg 2010-12-16 01:15:23 PST
This has been disabled for all mobile platforms by
http://hg.mozilla.org/mobile-browser/rev/7827ccd4bd19
Comment 8 Brad Lassey [:blassey] (use needinfo?) 2012-05-15 03:49:44 PDT
this happened with the merge of birch to mozilla-central in march

Note You need to log in before you can comment on or make changes to this bug.