spacing of fonts are bad in print preview and print output

RESOLVED DUPLICATE of bug 490475

Status

()

defect
RESOLVED DUPLICATE of bug 490475
9 years ago
9 years ago

People

(Reporter: yester64, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.6) Gecko/20100626 SUSE/3.6.6-1.2 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.6) Gecko/20100626 SUSE/3.6.6-1.2 Firefox/3.6.6

Problem is, that if you open a page for print in the preview window, the font renders the words in a very bad reading form.
Some word stick tight together, others are far apart.
I tried to change fonts, but it appears it is within firefox where i have no choice in changing the font. Or perhaps it is the render engine.
If i print the page, it is like in the preview. I zoom it to 70%, since 100% will cut words off. But thats another issue.

Reproducible: Always

Steps to Reproduce:
1.previewed this page http://www.h-online.com/open/features/GNU-HURD-Altered-visions-and-lost-promise-1030942.html?view=print
2.here a german version of the text. http://www.heise.de/open/artikel/GNU-HURD-Veraenderte-Visionen-und-verworfene-Versprechen-1046753.html?view=print
3.Results are same. Letters are to tight and some are to far apart.
Actual Results:  
Print preview and actual print are the same. Both look bad.

Expected Results:  
rendered the words together and space between words not within words.
Version: unspecified → 3.6 Branch
Group: core-security
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Version: 3.6 Branch → Trunk
I don't see the issue on Mac, but this might well depend on the particular fonts selected (which you _should_ have full control over, by the way) and might be Linux-specific....
Sounds like bug 490475, but please reopen if there are no fontconfig rules on your system that set hinting to true/1/on.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Summary: spacing of fonts are bad → spacing of fonts are bad in print preview and print output
Duplicate of bug: 490475
You need to log in before you can comment on or make changes to this bug.