If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Aero will randomly be disabled in Firefox and cause the "close button bars" to stop functioning.

RESOLVED DUPLICATE of bug 545892

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 545892
7 years ago
7 years ago

People

(Reporter: Dylan Xaldin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

This has been a issue for quite some time for me. Usually whenever I watch Youtube videos, Aero will completely disable itself making the firefox "glass" black and making the "x bars" completely nonfunctional. This first started happening in Firefox 3.6 when plugin container was introduced and I was using a aero theme. It still does the same on the default theme in Firefox 4.0 Beta 2.

Thanks for possibly fixing this in the future!

Reproducible: Sometimes

Steps to Reproduce:
1. Start watching a youtube video or anything that uses a plugin
2. Wait for aero to disable *random, but frequent.*
3. Done.
Actual Results:  
After clicking through several different videos, the 8th time my aero was disabled.


This happens on a custom aero theme in Firefox 3.6 & the default theme on Firefox 4.0.
(Reporter)

Updated

7 years ago
Severity: critical → major

Comment 1

7 years ago
This seems to more likely be related to your Windows settings than Firefox, unless your computer does not have sufficient memory to run Aero and streaming video at the same time.  If you have a laptop, your power settings may be set up to maximize battery life (which often turns Aero off) when playing video.  You may need to update your Flash player as well - can you post which version of Flash you're using?
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> This seems to more likely be related to your Windows settings than Firefox,
> unless your computer does not have sufficient memory to run Aero and streaming
> video at the same time.  If you have a laptop, your power settings may be set
> up to maximize battery life (which often turns Aero off) when playing video. 
> You may need to update your Flash player as well - can you post which version
> of Flash you're using?

I have 6GB of RAM & I'm using a Desktop with power settings set to High. My flash version is 10.1.53.64.

Thanks again.
(Reporter)

Comment 3

7 years ago
Created attachment 461418 [details]
Shows exactly what happens when aero disables in the browser itself.
(Reporter)

Comment 4

7 years ago
Disabling the plugin container has fixed the issue, but I would really rather keep it on. Thanks.
Update your quicktime.
(Reporter)

Comment 6

7 years ago
According to the Quicktime installer I just got from the apple site, My version already matches the one for download. :\

Comment 7

7 years ago
How exactly did you disable the plugin container?  I am not sure, but this may be due to process isolation.  Please un-disable the plugin container and try turning off process isolation just for flash:

browse to about:config
bypass warning
filter for "dom.ipc"
toggle the value for "dom.ipc.plugins.enabled.npswf32.dll" to false
restart browser, see if it works.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545892
(Reporter)

Comment 9

7 years ago
(In reply to comment #7)
> How exactly did you disable the plugin container?  I am not sure, but this may
> be due to process isolation.  Please un-disable the plugin container and try
> turning off process isolation just for flash:
> 
> browse to about:config
> bypass warning
> filter for "dom.ipc"
> toggle the value for "dom.ipc.plugins.enabled.npswf32.dll" to false
> restart browser, see if it works.

I do not have the value mentioned, I only have "dom.ipc.plugins.enabled" and "dom.ipc.plugins.timeoutSecs"

Comment 10

7 years ago
Oops, that was removed in 4.0 beta builds.  Right-click in the empty space, create a new boolean preference, for the preference name type "dom.ipc.plugins.enabled.npswf32.dll", and for the value put in false.
(Reporter)

Comment 11

7 years ago
(In reply to comment #10)
> Oops, that was removed in 4.0 beta builds.  Right-click in the empty space,
> create a new boolean preference, for the preference name type
> "dom.ipc.plugins.enabled.npswf32.dll", and for the value put in false.

I have done what you said and have no longer experienced the issue, but I no longer see the plugin container process running. Wouldn't that mean plugins aren't running in a separate process now? I have undone the plugin container disable I did earlier btw.
You need to log in before you can comment on or make changes to this bug.