Closed Bug 582875 Opened 10 years ago Closed 8 years ago

Secondary Sort order in Mozilla TB 3.1.1 is broken (compare with 2.0) when I sort by subject

Categories

(Thunderbird :: Folder and Message Lists, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 57898

People

(Reporter: miketm, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: 3.1.1

I have face the following problem when I change TB 2.0 to TB 3.0 
I read and answer to many letters every day. So everytime I need to sort my letter list by "Subject"

When I have few (for example 5-7) letters with the same subject and DO sort by "subject", the secondary sort-order in Mozilla TB 3.0 IS NOT "by send time" and IS NOT "by recieve order". There are not any secondary sort-order in TB 3.0, may be.

I have not got such problem in Mozilla tb 2.0

So this problem is exist at 3.0, 3.1,3.1.1

I use russian build. I try to find any answers in russian and english mozilla forums, but did't find any answers.

I try to find the solvation at Tools > Options > Advanced > General -> Config Editor, but unfortunatly I did't find anything.



Reproducible: Always

Steps to Reproduce:
1.Get a few letters with the same subject
2.have TB 2.0 in one hand
3.have TB 3.0 (3.1.1) in another hand
4.sort letters by "subject" in tb 2.0
4.sort letters by "subject" (same letter) in tb 3.0 (3.1.1) 
5.look - the order of letters is different! in mozilla 2.0 is good, in 3.0 (3.1.1) is bad
(get thee out of General)
Component: General → Folder and Message Lists
(get thee out of General)- sorry, what do you mean?
QA Contact: general → folders-message-lists
Ever since I got my 3.0 upgrade, when I try to sort by subject line, the entire program crashes.  The upgrades have not fixed this problem.  I use the sort functions frequently and I'd love it if someone could figure it out.
 Adrienne Lauby, Please create a new one bug. This bug is not about crash, it is about wrong sort order
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 57898
You need to log in before you can comment on or make changes to this bug.