ImageLib 2 breaks OBJECT images

VERIFIED FIXED in M9

Status

()

defect
P3
critical
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: newt, Assigned: pnunn)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
OBJECT images were fixed (i.e., enabled and nesting correctly) on 6 April as a
result of bugs 1945, 3692 and 4441.  They've been broken again since ImageLib 2
was checked in, as far as I can tell.  This is independent of the other PNG
problems (5459); PNG, GIF and JPEG images are all affected, as shown by the URL
above.  (http://www.cdrom.com/pub/png/pngs.html is a similar test page.)

Updated

20 years ago
QA Contact: 1698 → 3849

Comment 1

20 years ago
*** Bug 5858 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

20 years ago
Target Milestone: M9

Updated

20 years ago
Severity: normal → critical

Comment 2

20 years ago
As of the 5.11.99 build, viewing a PNG image via an OBJECT element crashes the
browser; raising severity to critical.

Updated

20 years ago
QA Contact: 3849 → 1698

Comment 3

20 years ago
[QA Assigning to self]

Talkback tracking ID of ELN37AMV for Mac OS crash.

Updated

20 years ago
Blocks: 5625
(Reporter)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

20 years ago
As far as I can tell, this is fixed as of 20 June 1999 or earlier.  I have no
idea who did what, but it's working fine under Linux for all of the test cases
I've got.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 5

20 years ago
Verified Fixed/can't reproduce using 7.9.99 5:00 PM builds on Linux/Win32 & Mac
OS. Thanks for checking!
You need to log in before you can comment on or make changes to this bug.