Extend copy paste support of Fennec's Qt port

RESOLVED FIXED

Status

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: antti.i.jarvelin, Unassigned)

Tracking

Trunk
x86
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8
Build Identifier: Mozilla/5.0 (X11; Linux armv7I; rv:2.0b3pre) Gecko/20100727 Firefox/4.0b3pre Fennec/2.0a1pre

Extend copy/paste support of Fennec's Qt-port

This includes:
1. Pasting text into html text fields 
2. Paste clipboard contents into editable html elements
3. Copy functionality for text & html contents of web pages
4. Cut functionality for text fields and content editable html elements
5. The user should be able to trigger the above actions using context sensitive menu or keyboard
shortcuts if keyboard is available
6. Users should be able to copy link locations into clipboard with context
sensitive menus.
7. Users should be able to copy image locations into clipboard with context
sensitive menus.


Reproducible: Always
Posted patch Fix proposal for fennec (obsolete) — Splinter Review
This is the fennec part of the copy-paste support
Attachment #461173 - Flags: review?(mark.finkle)
Posted patch Fix proposal for xulrunner (obsolete) — Splinter Review
This is the xulrunner part of the copy-paste support.  It extends the copy paste support of the xulrunner's Qt port.
Attachment #461174 - Flags: review?(mark.finkle)
Comment on attachment 461174 [details] [diff] [review]
Fix proposal for xulrunner

pushing the Qt part to Doug
Attachment #461174 - Flags: review?(mark.finkle) → review?(doug.turner)
Comment on attachment 461173 [details] [diff] [review]
Fix proposal for fennec

* Could you make the using: hg diff -p -U 8  (or similar)
* You have some extra files in the patch
* The ContextHandler was just updated to use a new method to register actions

Please update the patch.

We also need to check with the UX lead to see if all the new context menu items are wanted.
Attachment #461173 - Flags: review?(mark.finkle) → review-
Madhava - What do you think of adding the following to the context menu:
"Copy Link"
"Copy Image Location"
"Copy"  (for text)
"Cut"
"Paste"
Thanks for your comments, I'll update (both of) the patches.

(In reply to comment #4)
> Comment on attachment 461173 [details] [diff] [review]
> Fix proposal for fennec
> 
> * Could you make the using: hg diff -p -U 8  (or similar)
> * You have some extra files in the patch
> * The ContextHandler was just updated to use a new method to register actions
> 
> Please update the patch.
> 
> We also need to check with the UX lead to see if all the new context menu items
> are wanted.
This patch extends the copy/paste support of xulrunner's Qt port.

Now the patch format should be ok.
Attachment #461481 - Flags: review?(doug.turner)
Attachment #461174 - Attachment is obsolete: true
Attachment #461174 - Flags: review?(doug.turner)
http://hg.mozilla.org/mozilla-central/rev/0e00a31fb25c
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Posted patch Fix proposal for fennec (obsolete) — Splinter Review
Now the patch should be correctly formated.  Also updated the ContextHandler related code.
Attachment #461173 - Attachment is obsolete: true
Attachment #462000 - Flags: review?(mark.finkle)
Comment on attachment 462000 [details] [diff] [review]
Fix proposal for fennec

>+            <label value="&contextCopyImage.label"/>

XML Parsing Error: not well-formed (missing semicolon)
Comment on attachment 461481 [details] [diff] [review]
Corrected patch for xulrunner

I guess this is somehow landed already
Attachment #461481 - Flags: review?(doug.turner)
Blocks: 584225
Just the xulrunner part of the patch landed.

Fennec part still needs to be reviewed.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
Duplicate of this bug: 585875
Blocks: 590349
No longer blocks: 590349
Blocks: 585875
Resolve fixed. For fennec part there is now bug 585875.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Attachment #462000 - Attachment is obsolete: true
Attachment #462000 - Flags: review?(mark.finkle)
You need to log in before you can comment on or make changes to this bug.