Restore the toolbar control (pill) button in the main window

RESOLVED WONTFIX

Status

()

Firefox
Toolbars and Customization
RESOLVED WONTFIX
7 years ago
6 years ago

People

(Reporter: Emanuele Alimonda, Unassigned)

Tracking

({regression, uiwanted})

Trunk
All
Mac OS X
regression, uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

As suggested in bug 573412 and bug 578016, I'm opening a new bug entry about this.

The fix for bug 573412 was to remove the Toolbar Control ("pill") button from the Mac OS X title bar, which is against the Apple HIG, and also annoying to laptop users (13" ones, since the screen size is limited.)

This is a regression from 3.6 and 4.0b1.

Apple HIG are very explicit on this:
"The title bar should include a toolbar control if a toolbar is present in the window (see “Toolbars”)."

And this applies to all kinds of windows, not only to document ones, as it's been assumed in the bug 573412 comments.

source:
http://developer.apple.com/mac/library/documentation/userexperience/conceptual/applehiguidelines/XHIGWindows/XHIGWindows.html#//apple_ref/doc/uid/20000961-TP9

If Safari or Opera don't follow the guidelines, thus looking "broken", why should Firefox mimic them removing such button?  If the reason is to move the tabs to the title bar in future, it's not good, per Apple guidelines:
"The only controls that belong in a title bar are the close, minimize, and zoom buttons. If a title bar is combined with a toolbar, the unified area can contain the toolbar control and the toolbar customization contextual menu (these controls are described in “Title Bar Buttons”). Do not place other controls in a title bar."

Source: same as above

Reproducible: Always

Updated

7 years ago
Component: Shell Integration → Theme
OS: Mac OS X → Windows 7
QA Contact: shell.integration → theme

Updated

7 years ago
OS: Windows 7 → Mac OS X
Version: unspecified → Trunk

Updated

7 years ago
Component: Theme → Toolbars
OS: Mac OS X → Windows 7
QA Contact: theme → toolbars

Updated

7 years ago
OS: Windows 7 → Mac OS X
Alex, can we get a decision from the UX team, if we want to restore this button?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, uiwanted

Comment 2

7 years ago
What the pill button should do, IMHO:
* hide all toolbars except the tab bar
* disable the whole View → Toolbars menu

When clicked again, those two actions should be undone.

That's it. The tabbar should always be visible, regardless of whether there is one or more tabs, and it should not affect tab behavior in general.
Limi can weigh in on if he thinks this control is important enough to maintain. I'm personally in favor of removing it, since it's a strange step in between full screen mode and the normal window.

Comment 4

7 years ago
Please keep the Toolbars menu. All that was needed to be done was to remove the Tab toolbar sub-menu. FF4b2 already removed this entry, based on my running version.

However, we should move the "Display tabs above" away from the Toolbars menu.

So, once the "Display tabs above" sub-menu item is moved away, the pill button would be be able to show/hide ALL toolbars available under the Toolbars menu.

Comment 5

7 years ago
Small correction to my last comment:

The pill button should be able to show/hide ALL toolbars available under the Toolbars menu while keeping their individual state (displayed/hidden).

Comment 6

7 years ago
(In reply to comment #5)
> Small correction to my last comment:
> 
> The pill button should be able to show/hide ALL toolbars available under the
> Toolbars menu while keeping their individual state (displayed/hidden).

_toolbar_ is the keyword there. The Tab bar (and the Bookmark bar) are not toolbars, but scoped bars on OS X.
(Reporter)

Comment 7

7 years ago
(In reply to comment #3)

You're probably assuming a normal state that fills the whole screen area, which isn't the case for most OS X users.  Applications that follow HIG almost never fill the whole screen, so the Full Screen mode is very different from a window with collapsed toolbars (on a side note, the Zoom green button behaves incorrectly on OS X, but that's for another bug entry.)

On windows resizing:  "Don’t assume that the standard state should be as large as possible" http://developer.apple.com/mac/library/documentation/UserExperience/Conceptual/AppleHIGuidelines/XHIGWindows/XHIGWindows.html#//apple_ref/doc/uid/20000961-BACEDHFG

Comment 8

7 years ago
Oh, I'm missing this button. I currently have a Flash video open in a window resized to fit it perfectly. Hiding the toolbars would allow me to make the window much smaller. I don't see any problems with having the button there. Those who doesn't use it, doesn't have to. Please, considering bringing it back, it has use-cases.

Comment 9

7 years ago
(In reply to comment #0)
> If Safari or Opera don't follow the guidelines, thus looking "broken", why
> should Firefox mimic them removing such button?

On the contrary, if Apple doesn't follow Apple's guidelines, why should we follow Apple's guidelines? There may be arguments for the button restoration, but this certainly isn't one.

Comment 10

7 years ago
Isn't it enough that people miss that feature? I'm personally using it for having BBC's iPlayer in a separate toolbarless window, and it's really neat for me. I'm not saying this is a very frequent use case, but it is one.


What's even more important, I'm afraid that even if the pill button could be readded by an extension, it would result in the same bugs which caused its removal in the first place. Thus IMO the only way to make this bug actually fixable is to fix it in toolkit, and if we had that fixed, there would be no reason to keep that button away anymore.
FYI, there's already a fairly trivial add-on that restores this feature:
https://addons.mozilla.org/en-US/firefox/addon/215978/

Comment 12

7 years ago
(In reply to comment #2)
> What the pill button should do, IMHO:
> * hide all toolbars except the tab bar
> * disable the whole View → Toolbars menu
> 
> When clicked again, those two actions should be undone.
> 
> That's it. The tabbar should always be visible, regardless of whether there is
> one or more tabs, and it should not affect tab behavior in general.

Additional note: it would be very nice if this toolbar state could persist among sessions for each window. In 3.6, I have to hide the toolbar each time I restart the browser. for that iPlayer window.

Comment 13

7 years ago
(In reply to comment #11)
> FYI, there's already a fairly trivial add-on that restores this feature:
> https://addons.mozilla.org/en-US/firefox/addon/215978/

That extension is buggy. Any tabs is hidden and overall we save about 20 pixels.

Creating an extension to fix a bug is not productive. It's like creating an extension to have full screen, whereas it was choosen to create this inside Firefox.
(In reply to comment #13)
> (In reply to comment #11)
> > FYI, there's already a fairly trivial add-on that restores this feature:
> > https://addons.mozilla.org/en-US/firefox/addon/215978/
> 
> Creating an extension to fix a bug is not productive.

It is if the bug is eventually WONTFIX'ed. I just wanted to let people know there's an alternative. You can contact the add-on author if you think there are things that should be fixed.

Comment 15

6 years ago
I completely agree with Rimas. Please bring back the pill button, the extension is dodgy at best, the UI is often redrawn incorrectly based on active tab, etc.

Hiding all toolbars except the tab bar seems to make the most sense, imho. Perhaps even the tab bar could go, provided the "List all tabs" drop down button could be present next to the pill button to gain additional vertical space, whilst maintaining tab navigation via the mouse / keyboard...
If the "pill" is ever brought back, please recheck bug 366905, which I just closed as INCOMPLETE because it's moot until the pill does come back.

Comment 17

6 years ago
The pill button has been completely removed from the operating system in 10.7 Lion.

Comment 18

6 years ago
Thx @lowbatteries, you're completely right! Not sure it makes much sense keeping the discussion open if it truly has been removed at the OS-level :(

Moving forward, having Firefox support Lion's new full-screen mode ( e.g. https://bugzilla.mozilla.org/show_bug.cgi?id=63970 ) probably makes more sense in the long run, and essentially accomplishes the same task.

For older OS X users running newest Firefox builds, or those who may dislike entering full-screen mode to remove their toolbars, etc -- I guess the aforementioned "pill" add-on is probably their best bet.

Comment 19

6 years ago
(In reply to Zack Weinberg (:zwol) from comment #16)
> If the "pill" is ever brought back, please recheck bug 366905, which I just
> closed as INCOMPLETE because it's moot until the pill does come back.

Let's also mark that bug as depending on this one then.
Blocks: 366905
(In reply to lowbatteries from comment #17)
> The pill button has been completely removed from the operating system in
> 10.7 Lion.

Reason enough to close this, I'd think.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.