Enabled Extensions Should Appear at the Top of the List, Above Disabled Extensions, in the Extension Manager

RESOLVED DUPLICATE of bug 562232

Status

()

enhancement
RESOLVED DUPLICATE of bug 562232
9 years ago
9 years ago

People

(Reporter: tehbaut, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.0; WOW64; rv:2.0b3pre) Gecko/20100725 Minefield/4.0b3pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.0; WOW64; rv:2.0b3pre) Gecko/20100725 Minefield/4.0b3pre (.NET CLR 3.5.30729)

I know there's already an enhancement request to make enabled extensions more distinguishable from disabled extensions, but this one would take the cake on that, because it wouldn't require any toggling of settings, buttons, checkboxes, etc that would otherwise "drill down" into the desired selection of extensions. 

I propose that enabled extensions always appear at the top of the list, above disabled extensions, in the Extension Manager. I see now this was briefly mentioned in the other enhancement request, as a simpler solution to the more complicated recommendation, but I want to specifically highlight this request so as to try and speed along implementation of such a useful yet simple enhancement.

Reproducible: Always

Steps to Reproduce:
1. Open the Extension Manager via Tools > Add-Ons
Actual Results:  
Extensions are usually sorted alphabetically by 'Name' (though you can additionally sort by 'Size' or 'Last Update'), regardless of enabled/disabled status. 

Expected Results:  
Extensions should be sorted first by enabled/disabled status (enabled extensions at the top of the list), then followed by the default sorting method (Name) or other desired sorting method. 

The prioritization on listing enabled extensions first should probably be the case for all sorting methods, including 'Size' and 'Last Updated'. It just makes sense to do this that way.
I have already covered that reported issue with bug 562232.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 562232
Reporter

Comment 2

9 years ago
Sounds good. I hope you can get this implemented by the 4.0 official release.
You need to log in before you can comment on or make changes to this bug.