Status

P1
normal
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: rrosario, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
STR:

1) Register a new account
2) Login
3) Go to /questions

"An Error Occurred"

Traceback (most recent call last):

  File "/data/virtualenvs/kitsune/src/django/django/core/handlers/base.py", line 80, in get_response
    response = middleware_method(request)

  File "/data/www/support-stage-new.mozilla.com/kitsune/apps/sumo/middleware.py", line 80, in process_request
    user = auth.authenticate(session=session)

  File "/data/virtualenvs/kitsune/src/django/django/contrib/auth/__init__.py", line 50, in authenticate
    user = backend.authenticate(**credentials)

  File "/data/www/support-stage-new.mozilla.com/kitsune/apps/sumo/backends.py", line 33, in authenticate
    user = create_django_user(tiki_user)

  File "/data/www/support-stage-new.mozilla.com/kitsune/apps/sumo/backends.py", line 16, in create_django_user
    user.save()

  File "/data/virtualenvs/kitsune/src/django/django/db/models/base.py", line 435, in save
    self.save_base(using=using, force_insert=force_insert, force_update=force_update)

  File "/data/virtualenvs/kitsune/src/django/django/db/models/base.py", line 528, in save_base
    result = manager._insert(values, return_id=update_pk, using=using)

  File "/data/virtualenvs/kitsune/src/django/django/db/models/manager.py", line 195, in _insert
    return insert_query(self.model, values, **kwargs)

  File "/data/virtualenvs/kitsune/src/django/django/db/models/query.py", line 1479, in insert_query
    return query.get_compiler(using=using).execute_sql(return_id)

  File "/data/virtualenvs/kitsune/src/django/django/db/models/sql/compiler.py", line 783, in execute_sql
    cursor = super(SQLInsertCompiler, self).execute_sql(None)

  File "/data/virtualenvs/kitsune/src/django/django/db/models/sql/compiler.py", line 727, in execute_sql
    cursor.execute(sql, params)

  File "/data/virtualenvs/kitsune/src/django/django/db/backends/mysql/base.py", line 86, in execute
    return self.cursor.execute(query, args)

  File "/data/virtualenvs/kitsune/lib64/python2.6/site-packages/MySQLdb/cursors.py", line 173, in execute
    self.errorhandler(self, exc, value)

  File "/data/virtualenvs/kitsune/lib64/python2.6/site-packages/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue

IntegrityError: (1062, "Duplicate entry 'rlrtest2' for key 2")
From conversations in IRC:

It looks like this is most likely caused by garbage data on support-stage. There is a workaround we could attempt but it's probably unnecessary.

If this persists after we resync stage and/or on production after the 2.2 push, please reopen immediately.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.