Exchange server rejects emails with attachments from Thunderbird/Mac OS X

RESOLVED DUPLICATE of bug 579682

Status

enhancement
RESOLVED DUPLICATE of bug 579682
9 years ago
4 years ago

People

(Reporter: jim.abbey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.14) Gecko/2009090900 SUSE/3.0.14-0.1 Firefox/3.0.14
Build Identifier: 3.0.5

This is a long standing bug which is now becoming a "drop Thunderbird, go Entourage" mission for the owner of our company. Again.

Exchange believes that inline attachments containing apple specific mime headers are corrupt and bounces them.



Reproducible: Always

Steps to Reproduce:
1.Install fresh version of Thunderbird on Mac OS X
2.Send email to someone on early version of MS Exchange 2007
3.Attach a word/excel/ppt document
Actual Results:  
Email is returned to sender with this explanation:

"The e-mail system had a problem processing this message. Microsoft Exchange will not try to redeliver this message for you. Please provide the following diagnostic text to your system administrator.
 
#554 5.6.0 STOREDRV.Deliver; Corrupt message content ##"
 

Expected Results:  
The email should have been delivered to its intended recipient. 

We've been getting this for years now. It is often temporarily cured by:

1) Deleting the now infamous mimetypes.rdf
2) setting mail.content_disposition_type to 1
3) resending the attachment

The problem always comes back again however.

(It does seem to be about time that someone took a look at the whole mimetypes.rdf scenario. Almost all our problems trace back to that).
What makes you think the issue comes from Thunderbird ?

Is your exchange server patched ?
Component: General → Networking: SMTP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.smtp
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> What makes you think the issue comes from Thunderbird ?
> 
> Is your exchange server patched ?

I think this is a variation on bug 479169. It is a notorious failing of the Apple version of the otherwise excellent Thunderbird.

We don't have (yet) an exchange server, but all our clients do. They mostly run unpatched versions of Exchange 2007.

We are a 15 man service company with 1 IT guy (me).

They are mostly Fortune 500 companies with wall-to-wall IT guys and Exchange servers as far as the eye can see.

If I call them and suggest they update their entire email infrastructure to get over a bug in our preferred email agent they will at best laugh. At worst, they will cancel their account with us and I will end up serving hamburgers.

The rather impressive detail with bug report 479169 explains the issue better than I can.  It could be that Exchange 2007 is as much at fault as Thunderbird but we are in a David and Goliath situation and it's not obvious that we will move Microsoft or their users.
(In reply to comment #2)
> The rather impressive detail with bug report 479169 explains the issue better
> than I can.  It could be that Exchange 2007 is as much at fault as Thunderbird

So how about we only keep one bug ?
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > The rather impressive detail with bug report 479169 explains the issue better
> > than I can.  It could be that Exchange 2007 is as much at fault as Thunderbird
> 
> So how about we only keep one bug ?

Obviously, that makes sense except that 479169 was reported 18 months ago and the issue has, for us at least, become such a festering wound that I'm being ordered as I write to install Windows server 2008 R2 and Microsoft Exchange 2010. You can imagine how excited I am about that. I suppose the bug here is that the bug there needs to get fixed as a matter of some urgency.

Updated

4 years ago
Blocks: tb-mac
Apparently this should  be fixed via bug 579682
No longer blocks: tb-mac
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 579682
You need to log in before you can comment on or make changes to this bug.