Some images refuse to load when page is reloaded

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
8 years ago
8 years ago

People

(Reporter: shane.bundy, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100729 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100729 Minefield/4.0b3pre

When a Facebook page is reloaded, some images do not load.

Reproducible: Sometimes

Steps to Reproduce:
1. Go to a Facebook user's page
2. Reload the page
Actual Results:  
Some images do not show.

Expected Results:  
All images should show as normal.

Reloading the page again solves the problem, but not permanently.
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

8 years ago
Created attachment 461261 [details]
A screenshot describing the problem.
(Reporter)

Comment 2

8 years ago
Created attachment 461263 [details]
A screenshot describing what happens when the page is reloaded.
Shane, did this just start as of tonight's nightly?
Could be a dup of the regression from the redirect changes.

Updated

8 years ago
Duplicate of this bug: 582991

Comment 6

8 years ago
This did start as of tonight's nightly. Also, in case it wasn't obvious, it affects nearly every page, not just facebook.

What bug is the redirect changes and what bug is the regression?
OS: Windows XP → All
Hardware: x86 → All
Bug 513086.  There was no separate bug for the regression, just a followup fix pushed earlier today.

Comment 8

8 years ago
I'm seeing this on images that are not redirected at all, so I think bug 572520 (make all imgIDecoderObserver notifications asynchronous) is a more likely candidate.
Keywords: regression
Blocks: 572520
blocking2.0: --- → ?
Though "redirected" need not be just HTTP redirects... it can include stuff with proxies, etc, etc.  We'll know once someone tests a build with the redirect fix, I guess.
(In reply to comment #8)
> I'm seeing this on images that are not redirected at all, so I think bug 572520
> (make all imgIDecoderObserver notifications asynchronous) is a more likely
> candidate.

It is not, this is clearly what is described in bug 513086 comment 79 and fixed by patch in comment 87.

(We had to open a new bug for that regression, this bug could then be easily closed as dup of that)
So, are people still seeing this bug since the redirect fix landed? Honza's comment 10 implies that it should be fixed now.

Comment 12

8 years ago
This is indeed fixed for me now.
Fixed by attachment 461244 [details] [diff] [review].
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Resolution: FIXED → WORKSFORME

Updated

8 years ago
blocking2.0: ? → ---

Updated

8 years ago
Duplicate of this bug: 651194
You need to log in before you can comment on or make changes to this bug.