Update to Firefox 4 Beta 3 - What's New

VERIFIED FIXED in 4.0

Status

P1
critical
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: mayumi, Assigned: sgarrity)

Tracking

({verified-production})

unspecified
x86
Windows 7
verified-production
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
We're looking to launch Beta 3 next Thursday or Friday and so we'll need to update the What's New page.  I'm still finalizing the copy of the feature descriptions but I know that there are 3 features (Sync, JavaScript Values, SQLite 3.7.0). 
• Sync will be the highlight should occupy the top section; it will have a new video to replace Alex's App Tabs video (I’m trying to finish that on Tuesday next week)
• For Beta 3 we can get rid of the CSS transitions 
* And for Beta 3, the lower “Feature Showcase” box please keep the title and subtitle of that box as is, we’ll only have 2 features (JavaScript Values, SQLite 3.7.0), and keep the “More features >>” link where it is 

I'm trying to finalize the copy today or tomorrow morning.  The only other page that will need to be updated for this Beta will be the features page.  We'll just need to move Sync out of "What's coming" and add the other 2 under the hood features.  i'll file a separate bug for that.

Comment 1

8 years ago
Silverorange guys, will you be able to help with this? As noted in comment #0, we're still finalizing the copy, but wanted to give you a heads up now. Let us know...
(Assignee)

Comment 2

8 years ago
Yeah, we can help with this.
(Reporter)

Comment 3

8 years ago
Here is the updated copy

[top section]
Firefox 4 Beta now includes Sync: get instant access to all your important browser data - including bookmarks, passwords, history and open tabs - whenever and wherever you use Firefox.

Even if you have to rush out the door in the middle of an online project, Sync lets you pick up right where you left off on another computer or on a growing number of mobile devices. Watch the video to find out how to get started!
· Learn more about Sync » [http://www.mozilla.com/firefox/sync/]
· Share Feedback »
· Release Notes »

[lower left]
Speed Matters
The Awesome Bar, Download Manager and IndexedDB features are now faster and smoother thanks to an upgrade to SQLite, a SQL database engine.

[lower right]
Smooth Graphics
New JS Values means Firefox can execute heavily numeric code more efficiently, resulting in smoother graphics.

Comment 4

8 years ago
Thanks Mayumi. Steven, now that the copy is ready I'm assigning this to you. Can you guys get this ready by early next week so we'll have time for QA to take a quick look before the beta 3 launch?
Assignee: nobody → steven
Priority: -- → P1
Target Milestone: --- → 4.0
(Assignee)

Comment 5

8 years ago
I've got this copy dropped into the b3 whatsnew page in r71741. You can preview it here: http://www-trunk.stage.mozilla.com/en-US/firefox/4.0b3/whatsnew/

Does the support promo that we hid for b2 come back in this version? I'll adjust the width of the bottom columns once I know that.

Also, the main text "Firefox 4 Beta now includes Sync..." is a fair bit longer than the last beta. I've reduced the font size to fit into the layout.
(In reply to comment #5)
> I've got this copy dropped into the b3 whatsnew page in r71741. You can preview
> it here: http://www-trunk.stage.mozilla.com/en-US/firefox/4.0b3/whatsnew/
> 
> Does the support promo that we hid for b2 come back in this version? I'll
> adjust the width of the bottom columns once I know that.

I'm checking in to that--should have an answer shortly. 
> 
> Also, the main text "Firefox 4 Beta now includes Sync..." is a fair bit longer
> than the last beta. I've reduced the font size to fit into the layout.

I think Slater is going to try an cut down the text, so I'll let him jump in for that.

Thanks!
(In reply to comment #6)
> (In reply to comment #5)
> > I've got this copy dropped into the b3 whatsnew page in r71741. You can preview
> > it here: http://www-trunk.stage.mozilla.com/en-US/firefox/4.0b3/whatsnew/
> > 
> > Does the support promo that we hid for b2 come back in this version? I'll
> > adjust the width of the bottom columns once I know that.
> 
> I'm checking in to that--should have an answer shortly. 

The SUMO promos will continue to be hidden until Beta 4 (at the earliest).

> Thanks!
Two quick changes:

Can we put smooth graphics on the left and speed matters on the right? Also,
change the "Speed matters" header to say "SQLite 3.7.0".
Also, in the SQLite blurb, it should say "upgrade of SQLite" not "to SQLite".
http://www-trunk.stage.mozilla.com/fr/firefox/4.0b3/whatsnew/

On the localized template I am using the same width value for both features columns, I think it would look better on en-US as well (width: 390px)

Comment 11

8 years ago
Here's my suggestion for shortening the sync text (adds a small header and deletes the 2nd paragraph, basically):

<b>Now built-in to Firefox 4 Beta: Sync</b>
Go from work to home to mobile and back! Sync gives you seamless access to your important Firefox data - including bookmarks, passwords, history and open tabs - across multiple computers and devices. Watch the video to get started.


Laura or Mayumi should probably sign off on this before we start localizing.
Here is John's proposal on the localized copy with basic styling:
http://www-trunk.stage.mozilla.com/fr/firefox/4.0b3/whatsnew/
the page title says "Welcome to Firefox" like on firstrun, for 3.x whatsnew page the title is "Firefox Updated", should we use the former or the later?
Depends on: 583944
(In reply to comment #12)
> Here is John's proposal on the localized copy with basic styling:
> http://www-trunk.stage.mozilla.com/fr/firefox/4.0b3/whatsnew/

Approved. 
(In reply to comment #13)
> the page title says "Welcome to Firefox" like on firstrun, for 3.x whatsnew
> page the title is "Firefox Updated", should we use the former or the later?

Should be the latter, please.
Here is the draft of the l10n version with the video and subtitles:
http://www-trunk.stage.mozilla.com/fr/firefox/4.0b3/whatsnew/

I temporarily put the Theora version on the l1On server for testing, there is some work needed to slice up the sentences in shorter displayed strings. Getting late so I will do that when I am at the office this morning.
Looks great!  Thanks!
http://www-trunk.stage.mozilla.com/img/firefox/beta/4/video-app-tabs-thumbnail.jpg

for the beta 3, a thumbnail image should be added, the ones we use were for previous videos
(Assignee)

Comment 18

8 years ago
All text and video/thumb has been updated in r71784.

There's wasn't in the way of a visually appealing frame in the video for the thumbnail, so I went with a zoom-in of the Sync logo. Look ok?
(In reply to comment #18)
> 
> There's wasn't in the way of a visually appealing frame in the video for the
> thumbnail, so I went with a zoom-in of the Sync logo. Look ok?

Can we take a screenshot of the title page and shrink it down so the logo and "Firefox sync" are visible?
(Assignee)

Comment 20

8 years ago
Better thumbnail for the video in r71806.
The webm version of the video gets stucked at 47s on my machine and our French localizer's machine.
(In reply to comment #21)
> The webm version of the video gets stucked at 47s on my machine and our French
> localizer's machine.

That's weird. It's not doing it on mine--anyone else have the same problem?
(Reporter)

Comment 23

8 years ago
I sent an updated mp4 versino to Laura and Pascal to see if there was a problem when I compiled the video the last time ( file too big to attach to bugzilla).
I have people confirming the problem on Linux and Windows XP
I can confirm the video issue too, using:

Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100803 Minefield/4.0b3pre

Comment 26

8 years ago
The French localized version works fine on Mac OSX
Okay, Steven G--can we use SyncVideoV3.webm (in v.m.o) for the webm version and see if we resolve the issue?
Just heard that SQLite 3.7.0 is being backed out.  

For the Localized versions, I think we can leave sync in the top box and put the feedback button and text (from the first run page) back in that section. 

For en-US, we'll try and find a replacement for SQLite.
(Assignee)

Comment 29

8 years ago
(In reply to comment #27)
> Okay, Steven G--can we use SyncVideoV3.webm (in v.m.o) for the webm version and
> see if we resolve the issue?

I'm not seeing SyncVideoV3.webm in http://videos.mozilla.org/firefox4beta/
Depends on: 584231
Something isn't working right. I filed another bug to get IT to upload :(
ok, for locales we are now using the feedback button content for the lower part of the page, we will use it again as fallback in future betas if we face the same problem of features promotion changes.
I just managed to upload the new version of the video (under the same name) here: https://videos.mozilla.org/serv/firefox4beta/

Not sure if that changes anything.
The video is working for me on Linux, if QA can confirm that it works on Windows as well, I think we are fine.
I still have the issue with https://videos.mozilla.org/serv/firefox4beta/SyncFinal.webm using Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3pre) Gecko/20100803 Minefield/4.0b3pre.  Are we sure it's the video, and not the player?
still have issues as well, I probably looked in the wrong firefox window :/

Maybe use another tool than what you use to reencode the video in webm?
thanks, committed in r71841
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(In reply to comment #35)
> still have issues as well, I probably looked in the wrong firefox window :/
> 
> Maybe use another tool than what you use to reencode the video in webm?

As many of you may or might not know, Sync is no longer going to go in the beta 3 release. I know this is horrible timing, but unfortunately, I only found out a few minutes ago myself.  I'm meeting to try and regroup with mike and mayumi and see what the game plan should now be for this page. 

Stay tuned.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
In place of SQLite, please add:

"Multi-touch Support
Firefox now integrates multi-touch support for Windows 7, enabling you to
interact with your browser in a whole new way. "

We will be updating the top section with Test Pilot studies. I do not have the information yet, but will hopefully have something to add today or Monday.  I think Beta will not be going until Wednesday, so we have a bit of time.
(Assignee)

Comment 39

8 years ago
(In reply to comment #38)
> In place of SQLite, please add: "Multi-touch Support...

Done in r72074.
So, the Test Pilot stuff fell through.

This is what the page is going to be:

What's New in Firefox 4 beta

Multi-touch for Windows 7

Firefox now integrates multi-touch support for Windows 7, enabling you to interact with Web content in the most intuitive way--with your hands. Multi-touch, takes full advantage of Firefox ready, touch-enabled devices to give you a more enjoyable browsing experience.

Watch the Video to learn more (will add Paul R's video asap)

	•	Learn more about Mutli-touch [https://developer.mozilla.org/en/DOM/Touch_events]
	•	Share Feedback »
	•	Release Notes »


[Bottom Box]
Latest News 
Born to Beta

Who knew? Our beta users are 96% male. Less than a quarter of you were alive when the US put a man on the moon. And most use the internet to communicate. So...why not communicate a bit and help us get newbies testing Firefox?! We need feedback from women, non-techies and people who spend less time online, like baristas, elephant trainers, teachers, surfers or acupuncturists...

[Add Feedback button screenshot]

Smooth Graphics
New JS Values means Firefox can execute heavily numeric code more efficiently, resulting in smoother graphics.
Also, I think this may mean making stacking the content on the lower box instead of having it side-by-side. 

Thanks!
(Assignee)

Comment 42

8 years ago
Updates from comments #40/#41 done in r72132.
Oops--forgot to add something:

After "acupuncturists..." can we add "Tell your friends!" with a cool transform like what we did with "simply awesome" in the beta 2 whats new page?

Also, the feedback link in the top box has a "v" at the end.
(Assignee)

Comment 44

8 years ago
Comment #43 changes are done in r72146.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Still waiting on video--I'm uploading now.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Videos are here: https://videos.mozilla.org/serv/firefox4beta/

They are called "multitouch".
Severity: major → critical
FYI beta 3 is scheduled for tomorrow, ~noon PDT
One more thing-- can we make sure the release notes are linked to the beta 3 version? I'm not sure if that's something that happens automatically or not.
One more text change--

For "Smooth Graphics", please change it to say:

Title: "Smoother, Faster Browsing"
Text:"New JS Values mean that Firefox can execute heavily numeric code more efficiently, resulting in smoother graphics, less memory usage, and a faster browsing."
(Assignee)

Comment 50

8 years ago
(In reply to comment #46)
> Videos are here: https://videos.mozilla.org/serv/firefox4beta/
> They are called "multitouch"

These multitouch.* videos seem to be unusually large files. Most of the files video files are between 5MB and 15MB. These range from 26MB to 112MB. It looks like they are 1920 x 1080, when we're only displaying 640 x 360 on the page.
(Assignee)

Comment 51

8 years ago
(In reply to comment #49)
> One more text change...

Done in r72161.
(Assignee)

Comment 52

8 years ago
(In reply to comment #48)
> One more thing-- can we make sure the release notes are linked to the beta 3
> version? I'm not sure if that's something that happens automatically or not.

Oh, yeah, this was done in r72161 too.
On the 4.0b3 release notes page it says Firefox 4b2, http://www-trunk.stage.mozilla.com/en-US/firefox/4.0b3/releasenotes/

http://screencast.com/t/NmU0YzIyMTE

Not sure if this will change automatically.
(In reply to comment #50)
> (In reply to comment #46)
> > Videos are here: https://videos.mozilla.org/serv/firefox4beta/
> > They are called "multitouch"
> 
> These multitouch.* videos seem to be unusually large files. Most of the files
> video files are between 5MB and 15MB. These range from 26MB to 112MB. It looks
> like they are 1920 x 1080, when we're only displaying 640 x 360 on the page.

Added smaller versions here: https://videos.mozilla.org/serv/firefox4beta/ Have at them!
(In reply to comment #53)
> On the 4.0b3 release notes page it says Firefox 4b2,
> http://www-trunk.stage.mozilla.com/en-US/firefox/4.0b3/releasenotes/
> 
> http://screencast.com/t/NmU0YzIyMTE
> 
> Not sure if this will change automatically.

I think this is part of product details automatic changes--right, guys?
(Assignee)

Comment 56

8 years ago
I think the release notes just weren't finished yet. Beltzner updated them today. 

videos.mozilla.org seems to be down right now - will check back in a bit.
(Assignee)

Comment 58

8 years ago
(In reply to comment #57)
> 2 validation errors:

Fixed in r583075. Thanks.
(Assignee)

Comment 59

8 years ago
(In reply to comment #56)
> videos.mozilla.org seems to be down right now - will check back in a bit.

Apparently "scheduled downtime" (the best kind of downltime): See Bug 586271.
(Assignee)

Comment 60

8 years ago
The video/thumbnail has been updated in r72187.

I'm not sure why we have both:
http://videos.mozilla.org/serv/firefox4beta/ and 
http://videos.mozilla.org/firefox4beta/

The former doesn't seem to be synced to http://videos-cdn.mozilla.net/firefox4beta/
Looks good.  I'm calling fixed.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Damn--we have a typo:

"New JS Values mean that Firefox can execute heavily numeric code more efficiently, resulting in smoother graphics, less memory usage, and a faster browsing." should say "New JS Values mean that Firefox can execute heavily numeric code more efficiently, resulting in smoother graphics, less memory usage, and a faster browsing experience. Learn more [http://blog.mozilla.com/rob-sayre/2010/08/02/mozillas-new-javascript-value-representation/
]

Thanks!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Looks like Beltzner is fixed this.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Yeah, fixed on trunk in revision 72194.
Verified, FIXED.
Status: RESOLVED → VERIFIED
Keywords: push-needed
Keywords: push-needed → verified-production
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.