Cannot create an event on QMO

VERIFIED FIXED

Status

quality.mozilla.org
Website
--
critical
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
Steps to Reproduce:
1. Add new blog post
2. Add content
3. Click on Publish
4. Click "Yes" on Events Calendar plugin snippet on the bottom of the Post section.
5. Click on Update

Actual Results:
A blank page is shown and the post cannot be turned into an event.

Expected Results:
The blog post should turn into an event.
I can't reproduce this on locally or on staging. No idea what the problem could be.
(Reporter)

Comment 2

8 years ago
Yeah, it works fine for me on staging, but production is broken. Can you try it using the admin account on production with the "Testday: Mobile Firefox 2 Alpha 1" entry?
(In reply to comment #2)
> Yeah, it works fine for me on staging, but production is broken. Can you try it
> using the admin account on production with the "Testday: Mobile Firefox 2 Alpha
> 1" entry?

Yup, it is indeed broken in prod, and still no idea why. I notice that wp-admin is redirecting to https on prod but not on stage, so I wonder if that has anything to do with it? It shouldn't, but I'm just taking wild guesses. I don't remember if wp-admin was under https previously or if that's a recent change.
(Reporter)

Comment 4

8 years ago
Hey Craig, any luck deciphering this problem?
Unfortunately no, I'm still baffled. Especially since it works fine on stage but not in production. Which implies that the answer lies in finding the difference between those two environments. And since we can't duplicate the bug anywhere else it means we don't have a safe place to do any trial and error.

I did find a thread at http://wordpress.org/support/topic/plugin-the-events-calendar-posting-new-events-broken-after-upgrade-to-wp-30 describing the same symptoms but it's hard to know if it's the same cause. Someone claims to have fixed it by removing a non-essential line of code, but without a safe server to test on we won't know if that's our culprit.

So I'm afraid I'm stumped and really don't know what to try next.
(Reporter)

Comment 6

8 years ago
At this point, I think we'll need to try this fix out on production.
I've commented out the line mentioned in the support thread in r71940, but honestly have no idea if that's our culprit or not. This will be a blind test, and on a live site in production so fingers crossed. I have at least verified locally that the plugin still works without that line so even if this doesn't fix our problem it shouldn't break anything else. I've also included the update to the CMS Page Tree View plugin, which is totally unrelated and those updates will have no impact on this issue.

So we need to deploy r71940 to production and attempt to create an event post. If we still get the blank screen then I'm not sure what to try next.
(Reporter)

Comment 8

8 years ago
Great, I've filed a bug to start a push on Tuesday - https://bugzilla.mozilla.org/show_bug.cgi?id=584867
(Reporter)

Comment 9

8 years ago
This is fixed on production now.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.