Last Comment Bug 583197 - Accessibility: Message window To,From,Subject titles very feint and hard to see (grey text on a grey background)
: Accessibility: Message window To,From,Subject titles very feint and hard to s...
Status: RESOLVED FIXED
: access
Product: Thunderbird
Classification: Client Software
Component: Message Reader UI (show other bugs)
: 17 Branch
: x86 Windows 7
: -- normal (vote)
: Thunderbird 11.0
Assigned To: Andreas Nilsson (:andreasn)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-30 02:10 PDT by BJ
Modified: 2013-05-15 05:01 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed


Attachments
Shows normal colours - grey test on lighter grey (30.14 KB, image/png)
2010-07-30 02:14 PDT, BJ
no flags Details
Shows my particlular problem - title text becomes invisible (32.47 KB, image/png)
2010-07-30 02:15 PDT, BJ
no flags Details
super-quick patch to fix this (420 bytes, patch)
2010-08-03 07:30 PDT, Andreas Nilsson (:andreasn)
no flags Details | Diff | Splinter Review
the patch in action (screenshot) (22.45 KB, image/png)
2010-10-18 04:29 PDT, Andreas Nilsson (:andreasn)
no flags Details
updated patch (441 bytes, patch)
2010-10-18 04:33 PDT, Andreas Nilsson (:andreasn)
bwinton: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review
and using normal aero theme (screenshot) (10.07 KB, image/png)
2010-10-18 11:55 PDT, Andreas Nilsson (:andreasn)
no flags Details

Description BJ 2010-07-30 02:10:36 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729)
Build Identifier: 3.1.1

Not so much a bug but a plea to make something easier to see. Please see attachment TB311-headers1.png. This shows that when reading a message the To, From, CC, Subject titles are darker grey on a lighter grey background. Greater contrast between between text colour and background would be much appreciated.

But for me it's actually worse. I have tweaked my windows colour to make 3d Objects a darker grey in order that text stands out more. Unfortuneately this makes the To,From,CC,Subject title text invisible (see TB311-headers2.png).

The trend these days is to have minimal contrast between text colour and background colour. This makes life really hard for some of us. If people really think those colours schemes are good please at least let us change them.

Reproducible: Always
Comment 1 BJ 2010-07-30 02:14:10 PDT
Created attachment 461493 [details]
Shows normal colours - grey test on lighter grey
Comment 2 BJ 2010-07-30 02:15:44 PDT
Created attachment 461494 [details]
Shows my particlular problem - title text becomes invisible
Comment 3 BJ 2010-07-30 02:16:57 PDT
The solution may be to allow the title text to use the colour set by the Windows 3d Object settings. The backgrouond seems to obey these settings, why not the text?
Comment 4 Ludovic Hirlimann [:Usul] 2010-07-30 02:26:05 PDT
Have you tried safe mode? (see https://support.mozillamessaging.com/en-US/kb/Safe+Mode for more information) ?

Are you using non default windows themes ?
Comment 5 BJ 2010-07-30 02:38:48 PDT
Yes. I do not use the default Windows theme. Essentially I use an adaptation of the Windows High Contrast Black scheme. I need white text on a black background. But the Windows HCB as given makes it very hard to separate one window from another - windows all merge into a mess. So I set 3d objects to be grey (a slightly darker grey than the default). This makes windows stand out from each other and gives greater contrast with the 3d Object font colour.

I initially filed this as a request. Then when I thought that the 3d Object background colour setting had been used but not the 3d Object font setting I changed it to a bug.

I've been reply to emails that were only CC'd to me because I couldn't see who they were to. I don't recall this problem with TB2.
Comment 6 BJ 2010-07-30 02:47:12 PDT
To demonstrate the problem go to the Windows colour settings and select 3d Objects. Change the Oject colour to say orange and the text colour to say blue.

You will see the background of the message headers section go orange. But the title text (To, CC, Subject etc) stays grey and does not go blue.

It should obey the 3d Object setting.
Comment 7 Andreas Nilsson (:andreasn) 2010-08-03 07:14:45 PDT
Indeed, .headerName is hard coded to #888a85
I wonder if it might be a good idea to use opacity and set it to some percentage of the text color. This would mean that the color of them would be less prominent than the regular info.
Comment 8 Andreas Nilsson (:andreasn) 2010-08-03 07:30:12 PDT
Created attachment 462395 [details] [diff] [review]
super-quick patch to fix this

Try this!
Comment 9 BJ 2010-08-03 07:58:48 PDT
I can't find a messageheader.css file on Windows.
Comment 10 BJ 2010-08-03 08:05:16 PDT
I can't find a messageheader.css file on Windows.
Comment 11 BJ 2010-10-08 02:22:20 PDT
I've just turned on View All Headers to check the origin oa an email and deiscovered I have exactly the same problem here. The titles eg. "Received From" are barely visible to me in Windows default colours (grey text on a grey background) but completely invisible in the colour scheme I use.
Comment 12 Andreas Nilsson (:andreasn) 2010-10-18 04:29:09 PDT
Created attachment 483929 [details]
the patch in action (screenshot)

For Blake's review.
Comment 13 Andreas Nilsson (:andreasn) 2010-10-18 04:33:34 PDT
Created attachment 483930 [details] [diff] [review]
updated patch

Blake asked me via e-mail to add the /* lower contrast */ comment after "opacity: 0.5;" so we know why we're doing that.
Comment 14 Blake Winton (:bwinton) (:☕️) 2010-10-18 10:23:33 PDT
So, I like the code changes in the patch, but it sounds like BJ is still having the same problem, so I don't know if this patch actually fixes the bug.
Comment 15 Andreas Nilsson (:andreasn) 2010-10-18 11:16:24 PDT
BJ: Were you able to apply the patch to your local build?
Just want to double check if the problem still remains.
Comment 16 Andreas Nilsson (:andreasn) 2010-10-18 11:55:08 PDT
Created attachment 484037 [details]
and using normal aero theme (screenshot)

To ease review.
The previous screenshot was for HighContrast and Classic.
Comment 17 BJ 2010-10-19 04:51:11 PDT
I haven't applied the patch because I don't know how to. Also I use Thunderbird at work so it's difficult to find time. Do I need to compile from source somehow?

I'm still on public release 3.1.4
Comment 18 Blake Winton (:bwinton) (:☕️) 2010-10-19 08:05:30 PDT
Comment on attachment 483930 [details] [diff] [review]
updated patch

the grey-on-black is a *little* hard to read, but it's _way_ better than the previous version.  r=me, and thank you for the screenshots!
Comment 19 Andreas Nilsson (:andreasn) 2010-10-19 08:25:52 PDT
As I mentioned on IRC, it would be good to have a way to detect that you're running the High Contrast theme on Windows and make those labels all white in that case (like how one can detect if we're running Classic or Aero). Will open a bug and see if we can get some traction on that.
Comment 20 BJ 2010-10-19 09:49:20 PDT
I don't think it's that straightforward. The High contrast scehmes as givem by Microsoft are awful. I have modified it to suite my needs so the theme has the name I've given to it.

Why not just use the user set colours in TB for the labels as well as the data? Or allow the label colour itself to be set?
Comment 21 Andreas Nilsson (:andreasn) 2010-10-19 10:13:04 PDT
You can set the label color through your own custom Thunderbird theme, I would not like to clutter the preferences windows with that.

Even though the default HC theme is awful, I would assume most users who need a HC theme would select that anyway, based on the power of defaults.
Comment 22 BJ 2010-10-20 02:57:29 PDT
I haven't found the feature where I can set my own custom theme (beyond setting message font and background colour - which I set to white on black, and wish would propagate to all parts of TB and Lightning). I've searched the config editer and haven't found any options for header colour.

I've just installed 3.1.5 at home (3.1.4 at work tells me it's the latest version!). I see the header background colour is taken from the Windows 3d Object. Why not take the header font colour, and label colour, from the 3d Object setting too?

When viewing all headers I'd actually like a new window to open to show them. This would mean less scrolling where there are a lot of headers, and provide the ability to copy and paste them.
Comment 23 eionmac@btinternet.com 2011-07-17 07:07:20 PDT
In Thunderbird 5, the aero transparency makes all black text in headers  unclear. I had to switch of aero transparecy in all windows to ensure Thunderbird and Mozill Firefor was readable.
Comment 24 BJ 2011-07-18 04:33:21 PDT
I still have this probelm with TB5
Comment 25 eionmac@btinternet.com 2011-07-18 06:26:07 PDT
1. After much searching and experimentation, I found that Windows 7 'aero' transparency was on. This coloured the Thunderbird heading from my desktop background and the transparency of Thunderbird obscured the buttons and heading text written in black text. I switched off 'aero' transparency  and set borders to a light colour. Buttons now readable.
Comment 26 BJ 2011-07-18 07:34:20 PDT
Thanks but as far as I can tell I'm not using Aero.

When I reported the problem I was using XP which doesn't have Aero. Now I'm nusing a non Aero based theme and when I run the Aero trouble shooter it tells me I'm using a mirror driver (whatever that is) which doesn't support Aero.

I've looked and looked and looked and I can't find where you set transparancy off. But, as I say, I don't seem to be using Aero anyway.
Comment 27 Mark Banner (:standard8) 2011-08-16 02:58:54 PDT
Andreas: does this patch need landing?
Comment 28 BJ 2011-11-10 03:33:14 PST
Upgraded to TB 8 yesterday and this issue still stands.

Since the background colour is taken from the Widows 3D Object setting can I suggest that the text colour is also taken from the 3D Objects setting.
Comment 29 Blake Winton (:bwinton) (:☕️) 2011-11-10 09:35:34 PST
Yeah, I think you're still seeing it because the patch never landed…  :(

Let's see if we can fix that for now.  (I'm also going to request approval to push it up to aurora, cause it seems like a small, simple, worthwhile fix.)
Comment 30 Blake Winton (:bwinton) (:☕️) 2011-11-10 09:41:11 PST
Comment on attachment 483930 [details] [diff] [review]
updated patch

(As mentioned before, it's a simple patch that helps things, and should probably have been checked in a while ago.)
Comment 31 Jim Porter (:squib) 2011-11-10 09:43:46 PST
We should probably update this in the other places that color is used (off the top of my head, I think it's used for the attachment total size in the reader and composer).
Comment 32 Mike Conley (:mconley) - (Needinfo me!) 2011-11-14 07:11:55 PST
Checked in as http://hg.mozilla.org/comm-central/rev/0288e8d30965
Comment 33 Mike Conley (:mconley) - (Needinfo me!) 2011-11-16 06:41:36 PST
Committed to comm-aurora as http://hg.mozilla.org/releases/comm-aurora/rev/7136dac30fb3
Comment 34 BJ 2011-11-17 08:48:04 PST
(In reply to Jim Porter (:squib) from comment #31)
> We should probably update this in the other places that color is used (off
> the top of my head, I think it's used for the attachment total size in the
> reader and composer).

Checking or other places where this problem exists would be brilliant. I've just become aware of  bug 671119 where the Lightening developers are working on the same problem throughout the Lightinig UI.

This is all terrific. Thank you all.
Comment 35 BJ 2013-05-15 05:01:20 PDT
Please can we re-open this bug. The problem never did get fixed and is still there in TB 17.0.5. It now extends to the Show All Headers display. I used to be able to check the headers by viewing the message source but this facility seems to have gone.

If I repeated my original screen shots with TB17 they would look the same.

Since my orignal post my email address has changed. I'm posting this comment before I try to change my Bugzilla config in case I lose access to this bug report.

Note You need to log in before you can comment on or make changes to this bug.