IE: JS error on questions pages

VERIFIED FIXED in 2.2

Status

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: rbillings, Assigned: jsocol)

Tracking

unspecified
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
On multiple versions of IE, there is a JS error displayed if the user clicks 'ask this' with a blank field.

1. Open IE 7/8> log in
2. Go to Ask Question page:
https://support-stage.mozilla.com/en-US/questions/new?product=home&category=i1
3. Without Entering question on textbox, click on Ask button


Error: Line: 9
Char:9
Error: Expected identifier, string or number
code: 0
url:https://support-stage.mozilla.com/en-US/questions/new?product=desktop&category=d6&search=
(Assignee)

Updated

8 years ago
Assignee: nobody → james
(Assignee)

Comment 1

8 years ago
I was getting this error on most/all questions pages, not just by entering a blank question. Paul had the rash audacity to end lists with commas, which no other browser thinks is a problem.

I found two. Patch incoming.
Summary: IE: JS error when asking blank question → IE: JS error on questions pages
(Assignee)

Comment 2

8 years ago
http://github.com/jsocol/kitsune/commit/1a509dde5a8dc1f2cb0bb25944fbb905e4fd40ed
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 583334
Verified FIXED using IE 7 and IE 8; didn't test IE 6.  We'll do so as a final pass (in addition to ongoing).
Status: RESOLVED → VERIFIED
OS: Mac OS X → Windows XP
You need to log in before you can comment on or make changes to this bug.