default input type=text renders too large without any size declared

VERIFIED DUPLICATE of bug 25657

Status

()

P3
normal
VERIFIED DUPLICATE of bug 25657
18 years ago
18 years ago

People

(Reporter: ink, Assigned: rods)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20001027
BuildID:    2000102704

I have looked for this in bugzilla but have not been able to find it anywhere.

When you create a FORM tag and uses size="" mozilla renders the box wrong. If
you look at the url I have written you will see a example of the problem on a
page I was creating.
Mozilla does not give the FORM the right size if you do not use size tag. And if
you do use it and have a table that is 150 in wide and creates a FORM with
size="15" it will make it way to big. IE renders this correctly. Also when you
do not use the size tag.

Reproducible: Always
Steps to Reproduce:
Create a form in a table

Actual Results:  mozilla renders wrong.

Expected Results:  Render like Internet Explore
I'm looking at the page in both IE 5.0 and Mozilla at the moment.  The only 
difference is that Mozilla uses a different default size for input elements of 
type text that do not have a size specified.

If by the "incorrect" rendering you refer to the black rectangles, IE shows 
those as well for me.

Comment 2

18 years ago
Changing Summary.

Old Summary:Form size tag renders wrong.

The sample url uses transitional DTD, so I think it means that mozilla is
rendering in quirks mode.  Also, your font is Arial, a sans-serif font. This
means that mozilla, in quirky mode, will render the text input even larger.

This has been a well discused topic (bug 25657 and as early as bug 2486).

Suggest INVALID since bug 25657 was marked as such.
Summary: Form size tag renders wrong. → default input type=text renders too large without any size declared

Comment 3

18 years ago
marking a dup of bug 25657.

*** This bug has been marked as a duplicate of 25657 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Verified, this is a duplicate of bug 25657 "When does 18 = 29?  When you use the
SIZE attritbute in a text type input field."
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.