Properly handle exceptions in narcissus

REOPENED
Unassigned

Status

Other Applications
Narcissus
REOPENED
8 years ago
8 years ago

People

(Reporter: shu, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b3pre) Gecko/20100730 Minefield/4.0b3pre
Build Identifier: 

The eval function can throw errors which are catchable. The current narcissus exception code handles this very ad-hoc, should redo.

Should also improve the lexer's newSyntaxError to play nice with eval.

Reproducible: Always
(Reporter)

Updated

8 years ago
Keywords: narcissus
Some test cases, copied from the (dup) bug 584116:

    try { undefined() } catch (e) { print("caught") }
    try { unbound } catch(e) { print("caught") }

Dave

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 584116
Oops, marked wrong one as dup.

Dave
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Updated

8 years ago
Duplicate of this bug: 584116

Updated

8 years ago
Assignee: general → nobody
Component: JavaScript Engine → Narcissus
Product: Core → Other Applications
QA Contact: general → narcissus

Updated

8 years ago
Keywords: narcissus

Updated

8 years ago
Blocks: 584777
You need to log in before you can comment on or make changes to this bug.