[QAC generated] Lost A LOT of Tabs

VERIFIED INVALID

Status

()

Firefox
Session Restore
VERIFIED INVALID
8 years ago
8 years ago

People

(Reporter: dc, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Steps to Reproduce
---------------------------------------
1. Closed browser to free up memory
2. Save tabs and quit
3. Reopened

What should have happened:
---------------------------------------
Tabs usually persist after being saved/closed



What actually happened:
----------------------------------------
Tabs were all blank tabs
(Reporter)

Updated

8 years ago
OS: Windows XP → Mac OS X
Version: 3.5 Branch → Trunk
What version of firefox are you using?
Component: General → Session Restore
QA Contact: general → session.restore
(Reporter)

Comment 2

8 years ago
This issue happened on the trunk version of 4.0b3pre.

Comment 3

8 years ago
Did you have networking available when you restored the browser?
(Reporter)

Comment 4

8 years ago
Was I connected to a network?  Yes.
How many tabs/windows did you have open?
What websites?
Any flash/java games?
Any video sites?
Any media streaming?
What add-ons/versions do you have installed?
(In reply to comment #5)
> How many tabs/windows did you have open?
> What websites?
> Any flash/java games?
> Any video sites?
> Any media streaming?
> What add-ons/versions do you have installed?

In addition, how old was your session (ie. how long was Firefox open before you decided to close it)?
(Reporter)

Comment 7

8 years ago
> How many tabs/windows did you have open?
Guessing a few dozen

> What websites?
Mostly links to various blogs/articles/videos opened up from socialite

> Any flash/java games?
There might have been java/flash on some of the sites like youtube, but i don't think there were any games.
  
> Any video sites?
yes, not sure which ones

> Any media streaming?
yes, not sure which ones

> What add-ons/versions do you have installed?

I can email you the list privately if you'd like

In addition, how old was your session (ie. how long was Firefox open before you
decided to close it)?

1-24 hours?
> > What add-ons/versions do you have installed?
> 
> I can email you the list privately if you'd like
>

Thanks for getting back to me.  I'm not sure what your privacy concern is about add-on names and versions, but I always tend to lean on the side of respecting it.  If you wish to email me directly, my name on the bug comment is a link to my email.
You indicated in your email quite a list of add-ons installed.  34 by my count, and many affecting tabbed-browsing.  Can you try to reproduce this on a new profile with no add-ons installed?

http://kb.mozillazine.org/Profile_Manager#Mac_OS_X
(Reporter)

Comment 10

8 years ago
Since this incident occurred, I disabled almost all the add ons and have not had a recurrence of this issue.

Comment 11

8 years ago
do you have a sense of which add-on may have caused the problem?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 12

8 years ago
Sorry, don't think I do :/
Reporter, if you are willing to investigate for us, you can do so by disabling all add-ons then turning them on one by one until you reproduce the problem.

NOTE: It may not be a single particular add-on which is causing the problem, but a combination of certain add-ons.

Marking verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

8 years ago
Will let ya know if this happens again.
You need to log in before you can comment on or make changes to this bug.