Closed Bug 583519 Opened 9 years ago Closed 9 years ago

popup windows don't get opened in tabs anymore

Categories

(SeaMonkey :: Tabbed Browser, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: lam, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b3pre) Gecko/20100731 SeaMonkey/2.1a3pre
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b3pre) Gecko/20100731 SeaMonkey/2.1a3pre

Hi, in every version of SeaMonkey up to 2.0.6, pages opening popup windows using javascript are opening tabs. I consider this one of the most important features of SeaMonkey that still makes me use it over Firefox, if not the one most important feature.

However, I've tried 2.1a3 just today and it behaves just as Firefox and just happily opens windows when I click on forum attach buttons and stuff like that. This is a regression.

If you want SeaMonkey to be anything more than just a Firefox persona, this needs to at least be an option. I don't feel strongly about what should be the default, but an option to have it the old way is a must.

Reproducible: Always

Steps to Reproduce:
Click on any page that wants to open a popup window.
Actual Results:  
New window appears.

Expected Results:  
New tab should appear with the desired page.
This is just a preference setting, so not a bug. Neil or Philip should know what the preference name and setting is in detail.

Also, did we have plans to add UI for that one or not?
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
After like 2 hours of searching and fiddling, I think I found it:
browser.link.open_newwindow.restriction was 2, setting to 0 seems to help.

Just noting here in case someone else searches for it. It was a hell to find it :) I certainly hope it doesn't have any side effects ;)
http://hg.mozilla.org/comm-central/rev/f94de46e5976

    1.32 -pref("browser.link.open_newwindow.restriction", 0); 
    1.33 +pref("browser.link.open_newwindow.restriction", 2);

According to Hg Blame, KaiRo changed this in bug 505311 (SeaMonkey should default to tabbed browsing, r=Neil)
Blocks: 505311
(In reply to comment #1)
> Also, did we have plans to add UI for that one or not?
Well I seem to recall it being given as one possible justification of the creation of the new "Link Behaviour" preference pane.
You need to log in before you can comment on or make changes to this bug.