If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Larger-than-screen image in nested table does not engage horizontal scrollbars

VERIFIED WORKSFORME

Status

()

Core
ImageLib
P3
minor
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Andrew Wu, Assigned: karnaze (gone))

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [awd:tbl], URL)

(Reporter)

Description

17 years ago
In 1280x1024 mode, if I look at a webpage such as
http://www.gamespy.com/asp/image.asp?/articles/october00/thqday/rf2.jpg
which has an 1280x1024 image in a nested table, the horizontal scrollbars
do not appear.

If I click on view image and look at the image in a separate window without
any nesting or tables, the horizontal scrollbars appear in the new window
and I can use them. The original image in the original page, however,
still remains slightly obscured.

Note that the HTML does not give width or height information in the img tag.

Comment 1

17 years ago
Verified with personal build with trunk bits pulled 2000102905.

Is this imagelib not passing enough info to know that this image needs to create 
scrollbars, or is Gecko not paying attention?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
CC'ing self.

Comment 3

17 years ago
I also see this behavior on viewing an image only. See 
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=18255
Triaging Clayton's bugs. Reassigning to ImageLib component for first crack.
Could be Views as well...
Assignee: clayton → pnunn
Component: Layout → ImageLib
QA Contact: petersen → tpreston

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 5

17 years ago
Nominating
Keywords: mozilla1.0

Comment 6

17 years ago
evaughan: 
Are scroll bars in your domain?
-p
Assignee: pnunn → evaughan
Status: ASSIGNED → NEW

Comment 7

17 years ago
This looks more like a table bug rather than a scrollbar bug.
Assignee: evaughan → karnaze

Comment 8

17 years ago
This might be a dup of bug 56201.
WFM Win32 (Win2K) 2001071304

Comment 10

16 years ago
worksforme.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Whiteboard: [awd:tbl]

Comment 11

16 years ago
Verified WFM win98 build 2001103103
Status: RESOLVED → VERIFIED

Comment 12

16 years ago
Mass removing self from CC list.

Comment 13

16 years ago
Now I feel sumb because I have to add back. Sorry for the spam.
You need to log in before you can comment on or make changes to this bug.