Last Comment Bug 583588 - Crashes when download completes (successfully) -- always reproducible
: Crashes when download completes (successfully) -- always reproducible
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86_64 Linux
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://www.gutenberg.org/etext/1695
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-01 08:45 PDT by John Lindgren
Modified: 2011-08-22 17:47 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description John Lindgren 2010-08-01 08:45:52 PDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b3pre) Gecko/20100730 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b3pre) Gecko/20100730 Minefield/4.0b3pre

Using this nightly build:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2010/07/2010-07-30-03-mozilla-central/firefox-4.0b3pre.en-US.linux-x86_64.tar.bz2

Firefox consistently crashes whenever a download completes.

Reproducible: Always

Steps to Reproduce:
1. Load http://www.gutenberg.org/etext/1695 (for example, any page with a download link will do).
2. Right-click the link to http://www.gutenberg.org/files/1695/1695.txt, and save the file to the home folder (for example).
Actual Results:  
The download window comes up, the file downloads successfully, and then the crash reporter window comes up.

Expected Results:  
No crash. :)

Extensions installed:
Adblock Plus 1.2.1
NoScript 2.0

Plugins installed:
Java 1.6.0_20 (64-bit)
Flash 10.1 r53 (32-bit w/ nspluginwrapper 1.3.0-1)

Debian testing, Linux 2.6.32-5-amd64

I have submitted several crash dumps via the crash reporter on this, and I will try to attach one of them here.  I will also see whether this can be reproduced with all add-ons disabled.
Comment 2 John Lindgren 2010-08-01 08:51:14 PDT
Still happens with all add-ons disabled.
Comment 3 John Lindgren 2010-08-01 13:13:50 PDT
Seems to be fixed in today's build.
Comment 4 Tanner M [:Tannn3r] 2011-08-22 17:47:18 PDT
Appears to have been fixed as reported by the reporter.

Note You need to log in before you can comment on or make changes to this bug.